Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 430N RHB Updated with Garmin City Navigator 2014.10 NT

Join Wrangler Forum Today


Thread: 430N RHB Updated with Garmin City Navigator 2014.10 NT Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 09:15 AM
FingerTight
Quote:
Originally Posted by THUDDOME View Post
Sounds like you already have the latest unless you want to go buy the updates from here.com (2015). Not sure who says you need to burn anything, I never have, use a thumb drive. You could load HD transitions... what this thread was originally for. You need to know exactly what your maps are, 2014.40 or what because you need to match the transition file.
Excellent, appreciate the response!
Today 04:20 AM
THUDDOME
Quote:
Originally Posted by Broker23 View Post
Does any one know if this can be done?
It's a different transition file (Full Screen).
Today 04:10 AM
THUDDOME
Quote:
Originally Posted by FingerTight View Post
OK, just read every post in the entire thread (yes, didn't skip a one). I have a couple of questions here.

First, I'm working with a 2014 JKUS with a 430n (RHB14)
My map version is: OEM CN North America NT 2014
My software version is: 4.18 (50.xx, found it on another menu)

So - looking at what I've got here from the factory - it would appear I've got the basic 2014 map set and there are some later versions I could install? I'd like to confirm I don't have the latest already installed before I start downloading and burning things.

We live in an area of Austin with rapid expansion going on for the last 10 years, my brand new car has maps that are so out of date the navigation is all but useless. Luckily we know the area well so it's not *that* big of deal.

As for me, I'm plenty computer literate, just wanted to get some input here before I get after it.
Sounds like you already have the latest unless you want to go buy the updates from here.com (2015). Not sure who says you need to burn anything, I never have, use a thumb drive. You could load HD transitions... what this thread was originally for. You need to know exactly what your maps are, 2014.40 or what because you need to match the transition file.
01-23-2015 05:14 PM
FingerTight OK, just read every post in the entire thread (yes, didn't skip a one). I have a couple of questions here.

First, I'm working with a 2014 JKUS with a 430n (RHB14)
My map version is: OEM CN North America NT 2014
My software version is: 4.18 (50.xx, found it on another menu)

So - looking at what I've got here from the factory - it would appear I've got the basic 2014 map set and there are some later versions I could install? I'd like to confirm I don't have the latest already installed before I start downloading and burning things.

We live in an area of Austin with rapid expansion going on for the last 10 years, my brand new car has maps that are so out of date the navigation is all but useless. Luckily we know the area well so it's not *that* big of deal.

As for me, I'm plenty computer literate, just wanted to get some input here before I get after it.
01-22-2015 01:32 PM
nubby105
Quote:
Originally Posted by fwbtattooman View Post
My bad, I meant 50.xx
Damn, I thought you had something new.
01-22-2015 10:02 AM
fwbtattooman My bad, I meant 50.xx
01-22-2015 09:42 AM
nubby105 where did you find 52.xx.x?
01-21-2015 09:34 PM
fwbtattooman Thank you all for the awesome information. After reading and re-reading this thread I finally got the confidence to do the head unit firmtware update ( I hated the two tone blue color scheme ). It went very smoothly and now I have the 52.xx firmware and the black backround and love it. You guys rock!
01-20-2015 10:16 AM
nubby105
2015.30

I also tried updating on 50.xx and got excited for about 3 minutes until the error. I did get the PND updated when I tried it the first time on 33.xx.
Maybe someday there will be a fix, but I guess we are stuck here for a while.
01-18-2015 09:37 PM
THUDDOME
Quote:
Originally Posted by daveyjones View Post
the 2014.4 is the set map based of oct 2013 the file is continued over till oct 2014 then changes to 2014 map base for the 2015.3

if you load the 2014.4 file and look at the mapset it is 2013 base

Had some time tonight so I tried 2015.30. Tried it with 50.x firmware just for giggles. Went through and said PID Update Completed. Looking at map version it's still 2014

did you just use the usb folder like previous installs with folder/garmin and folder /garmin/jcv
using jetmouse? for unlock code

so if you did get the 2015.3 loaded and installed successfully it says map base 2014 congrats it is at most recent maps for North American maps good job

I gave up at 2014.4 installed from 2010 map base to 2013 and ugly blue screen 20.x.x.x to 50.x.x black what a difference
Unfortunately they didn't update. The file name and checksum are still 2014.
01-18-2015 07:23 PM
daveyjones Irishruler you get it completed
01-18-2015 07:20 PM
daveyjones
Quote:
Originally Posted by THUDDOME View Post
Had some time tonight so I tried 2015.30. Tried it with 50.x firmware just for giggles. Went through and said PID Update Completed. Looking at map version it's still 2014. Downgraded to 33.x firmware, tried again and then it said PID Update Failed. So then copied into 50.x firmware and ran and it gave me a screen I've never seen. It basically said it could not update NA Maps but could update Alaska, Canada and a few others. Let it do that but still lists 2014 in info. Weird stuff, not driving to Alaska to find out. I hope I didn't screw up my transitions...
the 2014.4 is the set map based of oct 2013 the file is continued over till oct 2014 then changes to 2014 map base for the 2015.3

if you load the 2014.4 file and look at the mapset it is 2013 base

Had some time tonight so I tried 2015.30. Tried it with 50.x firmware just for giggles. Went through and said PID Update Completed. Looking at map version it's still 2014

did you just use the usb folder like previous installs with folder/garmin and folder /garmin/jcv
using jetmouse? for unlock code

so if you did get the 2015.3 loaded and installed successfully it says map base 2014 congrats it is at most recent maps for North American maps good job

I gave up at 2014.4 installed from 2010 map base to 2013 and ugly blue screen 20.x.x.x to 50.x.x black what a difference
01-17-2015 04:11 AM
THUDDOME
Quote:
Originally Posted by nubby105 View Post
Thuddome
I have successfully updated maps from 2012-2014.40.
2015 does not work. Display reads that the maps are not compatible with the unit. (Tried 2015.10, 20, 30)
Had some time tonight so I tried 2015.30. Tried it with 50.x firmware just for giggles. Went through and said PID Update Completed. Looking at map version it's still 2014. Downgraded to 33.x firmware, tried again and then it said PID Update Failed. So then copied into 50.x firmware and ran and it gave me a screen I've never seen. It basically said it could not update NA Maps but could update Alaska, Canada and a few others. Let it do that but still lists 2014 in info. Weird stuff, not driving to Alaska to find out. I hope I didn't screw up my transitions...
01-16-2015 02:08 PM
Pinchy Nah, it's only stupid if you don't ask for help. :-)
01-16-2015 01:26 PM
irishruler Wow,
All this time staring at all of this and I never realized there were 2 generate buttons to push. I think I have been using the top one this whole time, Dont think I have ever tried the bottom one........Whole new definition of stupid!!!!!!!!!!!!! Thanks for pointing out my short comings and Ill be sure to try as soon as I get home.......
01-16-2015 12:15 PM
nubby105
Unlock Code

Quote:
Originally Posted by irishruler View Post
I was hoping you could help me out, I have got everything down on updating my map on my 430 radio, the only problem I am running into is creating a working keycode for my radio. I have used jetmouse 1.5 CF with radio ID and Cannot get a working code. I am using map 3187, like in your write up, but no go. I have tried locked and unlocked 2014.40. Any suggestions?

PM me your radio ID and I will punch it in and get you a code

Did you click the lower generate button or the upper? You must use the lower one.
01-15-2015 06:37 PM
irishruler
Quote:
Originally Posted by daveyjones View Post
after many attempts
1st I updated to 33.xx.xx.xx.xx using dvd page 3 has the download
2ng format usb fat32 using the 2014.2 gmapprom.img from TPB and JCV in root dir of the usb
Garmin/gmapprom.img and Garmin/JCV/D3060130A
the JCV should be in the same folder as the gmapprom.img
3rd tried 2014.2 with JCVd306...130a map and pnd successful
4th I had to use the jetmouse to get a serial code it worked like a charm
find the nav id number its 10 digits long in the about section in the nav settings and then using map id 3047 generate key its 25 digits long
5th using a Kingston data traveler 8 gig the usb stick has to be since win 7 first came out I used it as a boot usb for years I don't think the speed of the usb really matters
6th leave vehicle off put usb stick in front of deck and turn vehicle on
7th the 430n will boot the usb automatically reading files for about 15 mins or so then will say you want to update maps press yes another pop will come up say you have to purchase the update contact Chrysler
8th hit ok and the 25 digit bar comes enter the code you got with the jetmouse and that should start the nav update 1/1
9th map update complete pnd update complete
enjoy
I also did the 2014.4 from GPSUG and the JCV D3060130A with map id 3187 the same as above without a hitch and update to 50.0.xx.xx.x using dvd page 3 off the private server

thanks to all that put in the effort its frustrating and if it doesn't work reread the entire thread you will get it I had to read it about 6-8 times to catch it all

note make sure to use the correct version for the software install I tried to update with the Canada and Alaska maps only img and it error saying software north America + mexico is different bla bla bal

I then USed the CITY NAVIGATION NORTH AMERICA NT CNNANT2014.4.img it read no problem no conflict with update

I do believe most people are using the wrong img to try and update using only this or that check what software is installed already on the 430n and match it directly

if it says NORTH AMERICA or LOWER STATES OR CANADA AND ALASKA use the correct img

this whole process once I had the img files, firmware updates 33.xx and 50.xx, and jcv took about 2.5 hours

the whole process to get the files read to get it all done to this point was about 8 hours

and No I have not bothered to go any further with the 2015.1 or .2 files my map was 2011.1 its a totally different system no more blue screen not driving off the road into nothing

good luck
I was hoping you could help me out, I have got everything down on updating my map on my 430 radio, the only problem I am running into is creating a working keycode for my radio. I have used jetmouse 1.5 CF with radio ID and Cannot get a working code. I am using map 3187, like in your write up, but no go. I have tried locked and unlocked 2014.40. Any suggestions?
01-14-2015 04:59 PM
aldo90731
Quote:
Originally Posted by stroked250 View Post
Does this appear the same as the Navteq update?
No, it doesn't!

I have both, the 730N Navteq in my JKUS (and my Challenger before that) and the 430N Garmin in my JKR (an my JKUR before that).

IMHO the Garmin is far superior to the Navteq at so many levels: the Garmin has a much easier interface, more functions to play with on the trail like the Elevation display; you can customize the voices, the icons, the stats shown at the bottom of the screen, it shows you the current Speed Limit, etc., etc. The Garmin even has an Offroad Mode!

The only thing the 730N Navteq offers that the Garmin doesn't is Traffic Report, which I don't even use.

Thanks for heads up on the Garmin update. I am going to check it out!
01-14-2015 04:03 PM
irishruler What settings do I use on JEtmouse? Garmin mobile pc or garmin mobile XT, or does that even matter? Im going to pull all my hair out trying to figure out why this isnt working for me, but I only have a few more left after trying to do this seemingly easy task.
01-14-2015 03:04 PM
irishruler I have an RHB radio with OEM CITY NAVIGATOR NORTH AMERICA + MEXICO 2011
01-14-2015 03:01 PM
irishruler After reading all this thread I thought I had this in the bag. I downloaded both City navigator north america 2014.40 locked and unlocked, along with JVC file. I was on version 33 and didnt work but went down to 24 (I think it was)and still no luck. Nav unit reads the new map from usb but when I get to enter the unlock code, nothing I do works. I ran jetmouse 1.5 CF and put in my radio ID, then custom map and 3187 for the map im using. Not one of the codes unlocks my install. What am I doing wrong?????
01-12-2015 04:14 PM
THUDDOME
Quote:
Originally Posted by nubby105 View Post
Thuddome
I have successfully updated maps from 2012-2014.40.
2015 does not work. Display reads that the maps are not compatible with the unit. (Tried 2015.10, 20, 30)
I figured, when I talked with the guys at Navteq/Here.com they told me everything was about to change. I'm kind of interested in seeing what their maps look like. Maybe I'll dig into this again, I've been traveling so much for work I haven't had time to even drive my Jeep much less worry about the maps.

I know for most Garmin devices they do their own maps. In my Jeep was the first time I ever saw them farm out maps (which was Navteq). I've tried dropping the Garmin Topo maps on my 430, got them on there but there's no way to turn them on like on my other 2 Garmin devices. It's really dumb because Garmin could be cashing in on all of us selling us maps. Probably a contract thing with Navteq.
01-12-2015 03:03 PM
nubby105 Thuddome
I have successfully updated maps from 2012-2014.40.
2015 does not work. Display reads that the maps are not compatible with the unit. (Tried 2015.10, 20, 30)
01-11-2015 11:24 PM
THUDDOME
Quote:
Originally Posted by daveyjones View Post
READ FROM FIRST PAGE WORD FOR WORD DONT SKIP A SINGLE POST DONT ASK QUESTIONS THAT ALREADY BEEN ANSWERED MULTIPLE TIMES

read the thread buying the disk from the dealer is 2012 garbage 150 dollars for 3 year old maps almost the 2012 disk is based on sept 2011 released 3rd quarter of year

all related firmware maps are more current then dealer nothing new came out since 2013 for the 430n except maps 2015.1 2015.2 latest firmware 50.xx.xx which you get all free here
You cannot update maps through the dealer at all. That used to be Navteq which has now become here.com. If you buy the updates from here.com you will get the 2015 updates. The maps that everyone is downloading off the web are from them. This thread was never intended nor do we instruct folks on how to pirate software. This thread was to show how to use Garmin development to add hi-res transitions and other things available on the developer community. As I've stated in earlier posts, the 2015 updates are a complete re-write, new company, new format, etc.

FOR THOSE NEW TO THIS THREAD - What's being described in this thread is not for the inexperienced. If you want updated maps and are not real tech savvy you are better off going to here.com and buying the new maps. My warning comes from experience, not that I bricked my device (which I don't think is possible) but from talking to Jeep and Navteq and Garmin. You will have a challenge on your hands, they all point fingers at each other. The device itself is made by Mitsubishi which makes it even worse. Also for everyone hot and heavy about updating, the majority of the updates just provide address/business information updates. That's the majority of the data in the updates, not actual maps. I'm a tech guy and whether it's a phone/TV/blender everyone rushes out to update their devices and many get into trouble. If you can resist the urge to flash everything available you might be better off. When you get your device to not boot you will say to yourself "why didn't I leave it alone?" been there done that. Always remember, "if it ain't broke, don't fix it".

Lecture over -

BTW, I haven't tried 2015, started following my own advice, no need for updating. The firmware updates do provide functionality updates and those you should do. I know there's a 60 firmware out there but I don't think it's released to the general public yet.
01-11-2015 11:04 PM
THUDDOME
Quote:
Originally Posted by iherbivore View Post
Oh boy. I should not have done this. I have a2013 rhb. I started after reading a couple of these posts that were located on some other site. Lacking some important information, I put the 2015.10 files in a 50 update structure and burned to disc. The system tried to update and ended up in a boot loop state. I managed to install a 33 update after pulling the m12 fuse. Everything was functional at that point. I got the 2014.40 file and related jcv on a USB with folder structure listed in various posts in this thread. It would not update. It would ask if I wanted to update the maps but then stop moments after I said yes with a message that the process failed and a pnd not updated message. I tried going to the 23 version but still got the same problem with the map update. I went to version 50 which, as expected, would not even try to update the map. I spent some time updating between the system versions trying to get it to work. One time when I was updating to the 50 system version I got a prompt about updating the nav system from version 2 something to version 4 something (4.07?). I said yes and got a pnd update message and now ever since the navigation just shows a black screen. Going into nav settings also shows a black screen. I have switched around between 23,33, and 50 again but always the black screen now for nav. I can't update the nav with USB anymore because it always says no files on USB, like the nav system is totally fine so it can't even update. Any thoughts?
You can only update when you have firmware 33 installed. Your problem with 2014.40 sounds like corrupt files. As I've said before, don't use torrents. Garmin is very picky about files, one byte off and

There isn't really a boot loop with the 430. Once you turn the key off the device stays on for a period of time (to avoid rebooting during quick stops). The quick way to reboot is to pull the batt cable or fuse like you did.
12-31-2014 12:51 PM
sean79
Quote:
Originally Posted by daveyjones View Post
FOR THOSE WHO SAY THEY READ THE THREAD HA YA RIGHT 1 page back is complete how to do it or looking for the stuff needed

Pinchy and me both explain it best of ability besides doing it for you

read middle of page 15 it will save you roughly 4-6 hours of frustration

this thread is old and needs to be archive and restarted from a couple pages back and all the usual garbage deleted

you need 2 dvds and usb key

all above mentioned firmares 33.xxx.xx.and 50.xx.xx.
2014.4 and the needed jcv

burn each firmware to disc

use image burn its free

format usb stick fat32

make folder called garmin

put map in garmin folder
inside the garmin folder make jcv folder put the jcv in that folder

I tried to find maps without the keys needed no luck for me use the unit id number with custom map checked it will give you the 25 digit string of numbers on installing new maps after you hit generate jetmouse dl area has a how 2

on your deck where you go to settings and press about there in the top left corner will see unit ID

steps again

vehicle is off put dvd 33.xx.xx turn on ask to update say yes yes yes

once fully completed turn vehicle off insert usb from of deck usb turn key on it will read navigation update detected hit yes yes yes 25 digit key needed if done right and entered it will start the update instantly

fail recheck the unit id and redo with the key gen

once navigation is complete turn off vehicle load disc 2 50.xx.xx turn vehicle on just like you did on disk 1 the other yes yes yes for all prompts

read both our posts like I said on page 15 and for those who say they cant find the programs firmwares and maps all I can say is ...WOW

I have used the same disks and usb on 5 different vehicles using the key generator without a problem

We off to see the wizard the wonderful wizard of oz.... if I only had a brain
I did everything you say but nothing.
The error says was not able to update please contact dealer
12-08-2014 11:53 AM
nubby105
Quote:
Originally Posted by badge56 View Post
I just got a 2015 and the 430H . The maps are 50.1 OEM North America
So they exist.
Is that a 430N RHB? When it says OEM North America, there should be a year associated with it.

What exactly are you referring to with "they exist"?
12-07-2014 07:12 PM
relyt
Quote:
Originally Posted by badge56 View Post
I just got a 2015 and the 430H . The maps are 50.1 OEM North America
So they exist.
50.1 is the radio firmware and has nothing to do with how recent the map update is.
12-07-2014 06:44 PM
iherbivore Oh boy. I should not have done this. I have a2013 rhb. I started after reading a couple of these posts that were located on some other site. Lacking some important information, I put the 2015.10 files in a 50 update structure and burned to disc. The system tried to update and ended up in a boot loop state. I managed to install a 33 update after pulling the m12 fuse. Everything was functional at that point. I got the 2014.40 file and related jcv on a USB with folder structure listed in various posts in this thread. It would not update. It would ask if I wanted to update the maps but then stop moments after I said yes with a message that the process failed and a pnd not updated message. I tried going to the 23 version but still got the same problem with the map update. I went to version 50 which, as expected, would not even try to update the map. I spent some time updating between the system versions trying to get it to work. One time when I was updating to the 50 system version I got a prompt about updating the nav system from version 2 something to version 4 something (4.07?). I said yes and got a pnd update message and now ever since the navigation just shows a black screen. Going into nav settings also shows a black screen. I have switched around between 23,33, and 50 again but always the black screen now for nav. I can't update the nav with USB anymore because it always says no files on USB, like the nav system is totally fine so it can't even update. Any thoughts?
12-07-2014 03:19 PM
badge56 I just got a 2015 and the 430H . The maps are 50.1 OEM North America
So they exist.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:40 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC