Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > total loss of power

Join Wrangler Forum Today


Thread: total loss of power Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-09-2009 12:42 PM
Fishfearme well after exhaustive testing of other parts it turned out to be just that...exhaust! The Cat to be specific. runs great now.

Thanks for all the help and I hope this helps others.
08-01-2009 08:15 PM
Fishfearme i will, im sure i cant be the only one with this situation.

thanks for the imput dude.

im givin it up for tonight but back at it tomorrow.
08-01-2009 08:12 PM
jpdocdave yep...let us know how it goes.
08-01-2009 08:10 PM
Fishfearme duh, i knew that...been a long day under the hood. OK well i own a sawzall, just cut it off and see i guess....it'll be loud but tell me a lot.
08-01-2009 08:08 PM
jpdocdave tps is throttle position sensor.

you can always remove the cat temporarily and see if it goes over 25 to be sure.
08-01-2009 08:05 PM
Fishfearme and that would figure too since i just had the exhaust replaced from the CAT back....dang it.
08-01-2009 08:04 PM
Fishfearme that was my next guess, but would rather pin point this than throw parts at it. and at the risk of sounding stupid whats the tps?
08-01-2009 07:59 PM
jpdocdave most likely clogged cat. i've seen tps do it also, but usually with more irratic driveability at lower speeds also.
08-01-2009 07:56 PM
Fishfearme yes, but its really anemic. more you push the gas the slower it goes.
08-01-2009 07:35 PM
yjwes will it roll on flat ground?
08-01-2009 07:29 PM
Fishfearme
total loss of power

Ok, im stumped....95 yj with the 2.5 has been running great but the other day I went to get on the freeway and when I stepped on the gas the best I could do is 25 MPH. replaced the timing gears and chain but everything was fine there. replaced the rotor, cap, plug wires, plugs and I still have the same problem.

any ideas??

thanks guys.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:20 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC