Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > YJ idle problem

Join Wrangler Forum Today


Thread: YJ idle problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-28-2009 09:33 AM
whitebuffalo my idle goes all over the place too. ill check out that wire you're talking about
08-27-2009 09:52 PM
minderbinder3 I had similar issues before on my 91 2.5 and I replaced the wire connector and section of wires that joined the wiring harness to the rotor and that took care of it. It is a snap in connector with 3 or 4 prongs in the center. Check your wires there by moving them around while it idles to see if it messes with the idle. It should not but for some reason mine would get hot with the engine running and then would short out some where. To fix it I went and just cut the section of wires and connector out of one at the wrecking yard and replaced the bad wires. It only cost $2, but it caused a lot of frustration until I found the source of the trouble. No problems like that since.
08-27-2009 09:00 AM
strungxout
Quote:
Originally Posted by NAVYCHIEF View Post
what year and engine?
It's a 91 2.5L
08-27-2009 08:57 AM
NAVYCHIEF what year and engine?
08-27-2009 08:50 AM
strungxout
YJ idle problem

Ok well when I start it up it idles fine... somewhere right around 1k. If I let it just sit and idle for a minute it starts wanting to die. It bogs down to 3-4 hundred and then saves itself and shoots right back up to 1k. Sometimes it actually dies out... especially when I'm sitting at a red light haha. Takes a little bit to start back up again after that. The distributor case was cracked and the cap would wobble so I ussumed that was the problem, I replace the distributor (along with cap and rotor) and also plugs and wires. Still the same problem. Any ideas? Oh and also, there was a little gas leak that looked like it was coming out of the filter for about 2-3 days. Went and got a new fuel filter and before I had a chance to install it, the leak magically stopped. Don't know if that has something to do with it, or if this could be a common problem on these YJ's? I'd appreciate any help I could get. Thanks a lot.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC