Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > shifting issues

Join Wrangler Forum Today


Thread: shifting issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-30-2009 11:45 PM
sman68 im changing the tranny fluid tomo as i do not know when it was last done, got it from a dude at 133000 also picking up a rebuild kit for the steering box pretty sure an oring is bad, thanks for the help.
08-29-2009 11:20 PM
4Jeepn Check your hose connections for the power steering pump. as for the shifting, you have an AX-15. I would crawl under it and check the fluid level 1st. When was the last time you had the fluid changed? You will see a fill hole towards the side top area.. undo it, if fluid comes our or you can feel fluid with your finger, the level is good, next would be color.. and smell, burnt smell is bad along with very dark fluid.
08-29-2009 09:21 PM
sman68 yah its the power steering gear assembly, looked it up and it looks like this? this is of course after market but its leaking out of this i believe. like a redish or brown color. http://image.off-roadweb.com/f/83122...eering_box.jpg
08-29-2009 08:48 PM
Cons_Table im not sure about your first question. is your second question located on the driver side of your jeep? if it is, sounds like it might be your steering gear assembly.
08-29-2009 08:39 PM
sman68
shifting issues

hey guys got two questions, one im having some shifting issues from first to second, it shifts with no real grinds just is a good shove to get it in. also there is this "thing" under the front left side of the bumper that seems to be leaking some kind of oil or something. i have no idea what it is so pardon my ignorance. i drive a 97 wrangler 4.0l manual. thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC