Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > fuel problem

Join Wrangler Forum Today


Thread: fuel problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-07-2009 08:59 PM
NAVYCHIEF there are 2 check valves. one on the pressure regulator and one in the tank. tested with a pressure gage, if you lose pressure but it does not drop below 20lbs pressure it's the one on the regulator. if you lose to below 20 lbs, it's the valve in the tank. the haynes manual has all the particulars listed in the fuel system section. good luck.
09-06-2009 07:02 PM
NAVYCHIEF i looked at my parts catalog and could not find the valve. someone will come up with a location......not to worry.
09-05-2009 05:27 PM
81CJ is the check valve your'e referring to located in the tank?
09-05-2009 02:45 PM
tlrrob1000 X2 All your fuel is bleeding off back to the tank.
09-05-2009 07:53 AM
NAVYCHIEF backflow check valve. find it,fix it,forget it.
09-05-2009 02:03 AM
81CJ
fuel problem

94 yj 4.0 WHEN JEEP IS COLD IT WONT START. NO FUEL PRESSURE. IF I LEAVE THE KEY IN THE ON POSITION FOR 2 TO 3 MINUTES YOU CAN HEAR IT BUILD FUEL PRESSURE AND THAN IT WILL START. AFTER IT WARMS UP IT STARTS EVERY TIME. ALREADY CHANGED THE PUMP SAME PROBLEM

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC