Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Having problems installing hardtop

Join Wrangler Forum Today


Thread: Having problems installing hardtop Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-17-2009 05:21 PM
wranglermania Thanks Jerry looks like your way worked! I took off the hardtop again and instead pushed it a bit more forward for extra "slack" and pulled the latches in, then screwed in the bolts. starting to get a bit chilly up here so the soft top can only keep you warm for so long haha!
10-14-2009 07:38 AM
Rjsimms Not trying to hijack the thread, but I installed my hard top this weekend, and the back glass does not seal good against the tail gate. It looks like it is not aligned correctly. Did I miss something?
10-13-2009 04:15 PM
MCDavis I see your point, Jerry. I actually lock both of mine, but then unlock them before tightening the bolts. Don't really know why.

It's gonna rain like mad here for the next few days. I'm sure I'll find out quickly if the top's not quite in place!

TJ's have just 6 bolts? My LJ has 8. Guess they added one for the extra length.
10-13-2009 04:06 PM
Jerry Bransford
Quote:
Originally Posted by MCDavis View Post
I just put mine on today. I hook the front latches, put the bolts in, and then latch the latches. Fit perfect.
It often will but it's always safer to wait until the front is latched in place before you tighten the rear bolts. The reason being is the top can be slightly too far to the rear even with the bolts dropped in place for the front of the top to be far enough forward to latch properly. If the bolts are left loose, the front latches can pull the top forward more if needed to latch up properly. Then it's time to tighten the rear six bolts.
10-13-2009 03:56 PM
MCDavis I just put mine on today. I hook the front latches, put the bolts in, and then latch the latches. Fit perfect.
10-13-2009 01:36 PM
Jerry Bransford Hopefully you are latching the two front latches first, and only after the front is fully latched should the rear six bolts be tightened down.
10-13-2009 01:01 PM
jvc Is the hard top factory OEM ?

Also you may have the wrong year top for your Jeep.
10-07-2009 02:56 PM
Atthehop Hard top??? Whatever for?????
10-07-2009 02:39 PM
NeitherFanboy Sounds like the best solution is just to get a new hardtop. I will be happy to drive out and take that old one off your hands for you so it doesn't take up space around your place! :-)
10-07-2009 02:13 PM
SPDNJOE ^^^^ x2
10-07-2009 01:53 PM
HamiltonLJ Wow I never heard of the latches popping open! I always do the latches first then the bolts!
10-07-2009 10:54 AM
wranglermania well when i took it off everything was fine unlatched the latches and took out all the torx screws and voila, put it back on a couple weeks later and everything lined up fine no warpage anywhere put the bolts back in went to attach the latches back into the slots and its like i needed a bit of extra weight to latch them in. Perhaps i should try tipping the roof at the latches first, attach them, then screw in the bolts????
10-06-2009 10:58 PM
motokeen Did you have the hard top stored on a flat surface? If it was not it could have worped.
10-06-2009 10:50 PM
JeepnJim Perhaps you have an extra piece of weather stripping along the top of your windshield frame or a piece left on from your soft top mounting system. Sounds as if something is getting in the way up there sandwiched between your hard top and windshield frame. I just put mine on and the only resistance I felt when pulling the latches down was the compression of the weather strip. Is everything lined up and the back secured correctly?
10-06-2009 09:46 PM
wranglermania
Having problems installing hardtop

Has anyone had any problems with installing their hardtop? I installed it like it shows in the manual but i needed extra weight on top of the roof in order to latch the hinges back into the holes. Within 2 weeks both of them have popped back out again any suggestions????

cheers!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC