Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 4.0 Hard to start and bad miss when cold. Any suggestions?

Join Wrangler Forum Today


Thread: 4.0 Hard to start and bad miss when cold. Any suggestions? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-18-2009 06:07 PM
tracer012000
4.0 Hard to start and bad miss when cold. Any suggestions?

My 1997 4.0 has a really bad miss when the engine is cold espcially between 2000-3000 rpms. after about 5 to 10 minutes of running it goes away. i can drive for an hour with now problems then shut it off for fifteen to 20 minutes and it will do it again even though its not cooled all the way down. it also is hard to start, i have to crank and crank the starter for it to start. then once it does start it smells like raw gas. i've tried changing the entire distributer, several sets of plugs and wires, cat. converter, fuel pump, crankshaft pos. sensor,and have had the injectors cleaned. the check engine light comes on (sometimes). just wondering if anyone has had similar problems with their 4.0s and could offer a solution.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC