Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > tick...tick...

Join Wrangler Forum Today


Thread: tick...tick... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-24-2009 12:21 PM
motokeen My belt has been squeeling to so maybe I'll check both.
10-24-2009 11:16 AM
hishamsTJ i think stevens243 is right also check if ur main belt is rolling well i hade same problem and i checked everything was fine i ve changed main belt and sound of tick tick disappeared
10-24-2009 09:45 AM
stevens243 One of your relays is getting weak. The armature is supposed to be open (or closed) and is closing (or opening) for just a minute until the coil opens it back up.

It's probably for something you aren't using at the time that has power available.

When it's doing it, try touching the relays and you should be able to feel it snapping.

Ensure you have something more than 12v to 13.6v on the battery and if you do, replace that relay.
10-24-2009 09:23 AM
motokeen Yep. Same here but its randomn. DOesn't do it to often.
10-24-2009 09:18 AM
wranglersteve I have the same thing. Only when the heat or defroster is on. I have checked everything. Don't know what it is.........??
10-24-2009 04:35 AM
csamn2007 LMAO Bueller.

I would check for any loose wires and all grounds. No dimming lights when it ticks?
10-24-2009 01:00 AM
toplessartist
tick...tick...

I have a sporadic and non-steady ticking noise coming from the fusebox area (behind the glove box) It ticks *waits a couple four seconds* tick *waits two seconds* tick *ten seconds* tick ... in other words it isn't steady and it isn't consistant, but it sounds like a relay or a switch. It only happens on my '03, not on my '00. Everything works and I haven't blown any fuses or had any malfunctions. Been doing that since I got it (year and 3 months) and I kinda tune it out. I'd rather fix it.

Anyone? Bueller?

Thanks
Chris

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:59 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC