Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > high idle after cat back

Join Wrangler Forum Today


Thread: high idle after cat back Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-21-2009 12:15 AM
s3nt3nc3d Mine's only done it the one time since I posted about it in here... I wouldn't think a vacuum leak would be that sporadic. I'm still leaning toward the TPS sensor...but I honestly am stumped as well.
12-20-2009 11:08 PM
vballspen and the search continues. its weird i will have it in park to open my gates and it will idle high, then drive 100 more feet and it will idle were it should. could a vacuum leak be this sparatic or do i have bigger issues
12-16-2009 12:49 AM
s3nt3nc3d Figures after I reply to this mine started doing it too...I have yet to find a for sure solution. What I did to stop mine was I pumped up my brakes about 5 or 6 times real fast and on the last pump I held the pedal down. I'm not sure exactly what that does (something with the brake booster), but I noticed a long time ago that would drop the idle so low it'd nearly stall a vehicle out. When I did that, my idle dropped to normal and stayed there.

The ONLY thing I've changed recently that might be related to that is I bought a new TPS sensor...so you might be able to try that. They cost around $50.
12-14-2009 09:13 AM
vballspen i checked over everything and sprayed carb cleaner on all the vacuum lines no change. but as it sat there idling it would stay at 1500 then kick down to around 750 just for a couple seconds and then go back to 1500. i tried with or without air and made no difference. any other options?
12-08-2009 09:25 AM
s3nt3nc3d Exhaust shouldn't have had that kind of affect on it...your computer may have to relearn the exhaust a LITTLE bit, but nothing to that extreme. The relearning would mostly relate to slight adjustments to the fuel/air mix to compensate for the extra air flow through the engine, but the changes would be so minor, I don't think it would be noticeable at all other than to the computer.
12-08-2009 09:21 AM
vballspen thanks for the info. i will go over them today weather permiting. I know idle is controlled by the computer but would the new exhaust throw this off? or can it be adjusted?
12-08-2009 09:05 AM
s3nt3nc3d I think I've read the most common cause of a high idle is a broken/disconnected vacuum line...so that's prolly the best place to start looking. Maybe you snagged/cut one during the install.
12-08-2009 08:56 AM
vballspen
high idle after cat back

i installed a dynomax exhaust cat back 2 weeks ago and now my 97 4.0 idles at 1500 rpms. I replaced the iac motor and i got a little better but it is still intermittent. Sometimes it will idle at 750 when in gear but when i take it out it jumps back up to 1500 every time. the jeep and motor have 203000 miles and is developing a slight knock. I plan on a full rebuild in the next couple of months, but in the mean time what can i do to adjust the idle, could this be caused by the new cat back?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC