Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Calling all AEM Bruteforce owners

Join Wrangler Forum Today


Thread: Calling all AEM Bruteforce owners Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-15-2009 09:03 AM
mrcarcrazy definitely glad to hear they stepped up to the plate on their own. impressive this day in age.
12-14-2009 04:17 PM
Timberman UPDATE:
Well, I called AEM this morning and the lady was eager to send me out another plug no questions asked.. Cool Right? Well, I received a call a little later today and it was a gentleman who stated that since they have already sent me a replacement plug once before he was a bit concerned.. Since this hadn't happened before, he was concerned with the hole itself..

So, instead of sending me another plug, they are going to replace the entire tube just to make absolutely certain this doesn't happen again!

Its finally nice to report on a company which actually cares about their customers!!

HUGE KUDOS to my friends at AEM Power..

Guess which kind of intake I will be installing on my JK Unlimited when the time comes?? Yup, she will have an AEM even if they are way more money!
12-13-2009 07:33 PM
Timberman
Quote:
Originally Posted by omgwtfbbqcopter View Post
do you mean the plastic plug on top of the cone? If so, just glue it back in.
No, it is the plastic plug on the actual tube itself..
12-13-2009 06:06 PM
2002Apex have the same intake.. 2nd one to be exact. never had a problem. unclear to which plug your talking about?
12-13-2009 01:54 PM
jgano23 sorry timberman, i have that intake, but have never had this, or any, problems with it.
12-13-2009 01:36 PM
omgwtfbbqcopter do you mean the plastic plug on top of the cone? If so, just glue it back in.
12-13-2009 10:09 AM
Timberman Looks like its just me who is having this problem... Seems to be par for the course as of late...
12-12-2009 07:37 PM
Timberman
Calling all AEM Bruteforce owners

Hello!

I am having a little bit of an issue with my AEM Bruteforce intake.

The little plastic plug has fallen out twice.. I just discovered this a few minutes ago and this was the second time.

I called AEM last time and they gladly sent me another one, but it fell out too.

The person at AEM stated that this has never been an issue.. Leave it to me!!

So, has anyone else had any problems with the plastic plug falling out? If so, what was your remedy?

Thanks

Timber

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC