Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > A/C & Defrost Problem

Join Wrangler Forum Today


Thread: A/C & Defrost Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-05-2010 11:18 AM
burton160w UPDATE! While I haven't looked at the resistor yet, now my Jeep's blower won't turn off when the key is out of the ignition!
01-03-2010 09:14 PM
MTWanderer The most common reason for having only the low and highest blower motor speed is a Blower Resistor that has reached the end of it's life.

Not an expensive part (around $20) installs behind the glove box, though it is easiest to reach from under the dash (Easy is a relative term)

Search on Blower Motor Resistor .. I found the topic well covered.
01-03-2010 09:00 PM
terrible2 atleast youre not without AC in Hawaii. Im sweating and its even winter.
01-03-2010 07:43 PM
burton160w
A/C & Defrost Problem

So my air conditioner and defrost has been having a problem lately. I have commented on it before, but here's the rundown.

1) The car squeals LOUDLY starting up if the A/C or defrost is on for only about 10 seconds. I finally attributed this to the a/c compressor.

2) The defrost, blower, and a/c only work on high.

3) Their is a popping sound that can be heard when the defrost is first turned on.

4) The defrost doesn't always turn on first time, and often only air blows out of the front air vents, not the top, and makes a horrible squeal different from number one.

Any suggestions? Obviously my air compressor has gone as per number one, but I have no idea what all needs to be done to fix it. The swap itself is fairly easy from what I have read, but there are other things to be done I don't know about. And then what about problems 2-4, the air compressor does not necessary explain those issues.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:23 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC