Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Question, please help!

Join Wrangler Forum Today


Thread: Question, please help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-12-2010 03:45 PM
NAVYCHIEF good on ya. those flashers can be toughies.
01-12-2010 03:03 PM
93wrangler Update. I got the flasher replaced...just had to man up and show it who is boss. But everything works great now.
01-12-2010 01:22 PM
NAVYCHIEF the flasher pulls straight out. they may be a little corroded.
01-12-2010 01:07 PM
kirok I'm experiencing the same problem. Replaced all the indicator lights and it does not blink on and off when I engage it. I will check on the flasher. Thanks.
01-06-2010 02:29 PM
93wrangler alright, may sound stupid but how do those flasher fuse things come out, i see something that says turn but I don't feel it makes any difference.
01-06-2010 08:09 AM
RedWrangler I've also seen this happen when a bulb burns out in some cars. DK if it's the same in the jeep. Check to see if all of the indicator lights light up on that side.
01-05-2010 10:43 PM
93wrangler thanks guys! I will give it a try tomorrow and report back!
01-05-2010 08:32 PM
NAVYCHIEF swap it out with the emerg flasher,right next to the turn flasher, for a quick test.
01-05-2010 08:01 PM
95riogrande x2 bad flasher
01-05-2010 07:44 PM
scott howard Sounds like you have a bad flasher.
It is the round canister (silver) located on the upper left of the fuse box.
They are very cheap at any parts store
01-05-2010 07:38 PM
93wrangler
Question, please help!

Alright, so my turn signal is sort of malfunctioning. When I move the lever to engage the passenger side turn signal all goes according to plan, when I move the lever to engage the drivers side turn signal the light in the dash comes on, the turn signal lights on the front/back come on but they don't flash like they are supposed to, they just remain in the on position.

Any ideas?

Thanks!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC