Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Another Newb

Join Wrangler Forum Today


Thread: Another Newb Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-27-2010 11:04 PM
up2nogood Thanks, working on some pics this weekend, gotta get this heater going first!
01-26-2010 11:14 PM
JDsDream Welcome to the forum. Post some pics in the Jeep Profile.
01-26-2010 09:43 PM
up2nogood VARedLeg82 - I take it you are in the ARMY, I was in for 5 years myself, I'd like to tell you, thank you for your service and dedication to our freedom.
01-26-2010 09:33 PM
up2nogood Thanks, i'll check it out SOON, cause i'm freezing my ass off on the way to work! I just love driving my Jeep, should have bought one years ago! The noise seems like an easy fix, I hope the heater is too!
01-26-2010 12:29 PM
dan188 heater issue is definitely common. My 98 had a stuck blend door, so when I moved the temp control lever I thought I was changing the heat but really I wasn't doing anything.
01-26-2010 12:37 AM
distortedtj Welcome to the forum.

Heater issue....Check to see if your blend door is broken...common.

Sweak issue.... Common with alot of vehicles. Usually just the back of the steering wheel rubbing on the plastic cover over the column.
01-26-2010 12:21 AM
VARedLeg82 I'm not real sure about the heater, because most wranglers come stock with the "burn your @$$-hairs" heater.

As for the squeak, go inside the engine compartment and look at where the steering column comes through the firewall. There's a rubber boot there that if you lube it up, the squeak will go away. It's a pretty common problem, so no worries.

Welcome, and happy wheeling!
01-25-2010 11:45 PM
Storm27m Mine does the same squeak. I figure it's something I need to lube up but I haven't got around to it yet. I'll be following this thread to see what people say. Sorry, but I can't help with your heater issue.
01-25-2010 10:30 PM
up2nogood
Another Newb

Hi guys and gals, another newbie here........ I just purchased a Red 97' hardtop sport, 4.0, 5 speed. It runs great, but the heater doesn't blow hot at all and the steering wheel/column makes a low pitch squeak the first time you turn it in the morning.

The engine gets right up to @180° in a couple of minutes, but very little heat even with the fan on full blast. It also seems that the amount of air blowing out isn't proportional to the jet turbine exhaust sound emminating from the dash. I searched a couple of threads on the heat issue, but haven't had the time to try anything yet.

I look forward to having a great time and learning a lot on this forum, so see you later.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC