Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Fuel level sensor / check engine

Join Wrangler Forum Today


Thread: Fuel level sensor / check engine Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-09-2007 04:41 PM
Rawkon what code was the engine light giving you? i have a complete factory service manual for our TJs

You can do a calibration /test on your gauges by holding down the tripodometer button and turn the key to the on off on off on and leav it on. the comp will tell you what stored codes you have on the odometer and then do a gauge test. everything goes wacky for a couple minutes then it shuts down.
02-09-2007 02:13 PM
MouthfulOfGrass
Fuel level sensor / check engine

I've had this issue since I got the Jeep (used) and I thought I'd write about it.

When I got my tj it had a check engine light on. Previous owner told me he would just disconnect the battery and it would go away for a while. What he didn't tell me was that the fuel gage would, at random times, register empty and the low fuel light would light up. Then the check engine light would show after this happened a time or 2. I changed an O2 sensor that was also throwing a code.
I read that higher sulfer content in some cheaper gasolines will cause a buildup on some sensors and cause them to fail or error. I also read that Chevron makes 1 additive that will help to clean excess sulfer from sensors, I tried it. Also read what Gas companies have less sulfer content in their gas and started using only gas from those companies. (It was an article in Westways magazine, put out by AAA - autoclub - I don't remember all the details and don't have the mag handy).
I'm happy to say that, between the additive and gasoline, the problem has just about dissappeared. In the 3 months following I only had 1 reoccurance of the fuel gage problem/low fuel light/check engine light. The tank was low at the time, and after filling the tank everything went back to normal.
I know that I should change the fuel level sensor, and will do so when I drop the tank to convert it to the 19 gal. that it is supposed to be. But until then, I am happy with the results of this "fix".

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC