Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Lost the dashboard lights

Join Wrangler Forum Today


Thread: Lost the dashboard lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-15-2007 06:45 PM
Dare2BSquare Sounds like you are on the right track. Maybe the moisture and the freezing temps finally got to the electrical parts.
02-15-2007 06:23 PM
R.P.M.
Lost the dashboard lights

'93 YJ Lost the dashboard lights...
It has been cooold here in Michigan, was about 2 degrees this
morning as I was driving to school, when I lost the dash lights.
Checked it out and was also missing running (side lights also).

Found 2 blown fused 1 fixed running lights and the other was
a 25a fuse labeled acc lps, Im guessing accesories / lamps.

I replaced the second fuse and burned out (as in smoke and flames) the reostat that controls (dimms) the dashlights.BUT
did not blow the fuse? That makes me think that it was just the
reostat ( its located to the right of the headlight switch).

I cannot find any bare wires under the dash... It may have been
a moisture problem left over from water leak that took out the stereo 2 months ago. But that was replaced by the pro this time. Any thoughts before I burn up $40. on a new reostat?

New part is in transit, but Ill continue to recheck wiring.

Oh i also checked the cig/acc port to make sure nothing had fallen in.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC