Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Lift installed, have question

Join Wrangler Forum Today


Thread: Lift installed, have question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-01-2010 07:42 PM
Storm27m Ha ha ha....so maybe I am the first dumb*** to do it. It is the plastic nipple that broke. It looks pressed in because there are no wrench flats. I'll have to look around a bit on google and see what I can find out. I didn't forget to disconnect the back one, but I did replace that brake line and had to remove the vent on the rear to get it off. It came out no problems. Thanks again
03-01-2010 07:27 PM
Jerry Bransford I would just re-center the axles as well as you can visually. There is too much stuff in the front & rear like trackbars etc. to worry about clearance around them if you start trying to increase the wheelbase too much.

You broke the nipple that the air vent hose slips over? In the rear, it is threaded in so the remaining piece (which also holds the brake line splitter block to the axle) can be removed with a big ez-out or similar. I'm not sure if the front vent nipple is pressed or threaded in, I've never had that one out.
03-01-2010 07:20 PM
Storm27m Thanks Jerry...didn't think about that. So how close to center should I be shooting for?


Also, forgot to mention in the first post, but I forgot to disconnect the diff vent line and snapped it at the diff housing while installing the lift. It looks like a plastic piece, but didn't see an easy way to remove it. Any way to replace this or do I need to rig something. Surely I can't be the first dumb*** to do this?
03-01-2010 07:09 PM
Jerry Bransford Suspension lifts shorten the wheelbase a tad, just lengthen all of the arms an equal number of turns until they are where you want them. Don't forget that as the suspension compresses & the tires stuff up into the wheel wells that the front axle moves forward & the rear axle moves rearward.
03-01-2010 06:56 PM
Storm27m
Lift installed, have question

I installed my lift this weekend and have a question regarding centering the tires/axles in the wheel wells. I went with the Rough Country 4" x-series lift, so I have all 8 adjustable control arms. My wheels aren't exactly centered in the wheel wells (see pictures). Anyone have any tips to get things centered or do I just keep messing with the control arms until I get it right? I'm thinking that I just need to figure out how far from center I am and then split the measurement in half and add that amount of length to the control arms? Like if I was 1" from being centered, I'd add 1/2" in length to each of the control arms as a starting point?

Here's the before.....


and here's the after.....


Rough Country 4" X-series lift
Cragar Soft 8's
33x12.50 Mickey Thompson MTZ's

The pictures are a little crappy from cheap camera and dust in the bays. I've still got to install my SYE and driveshaft so I haven't got to drive it other than getting it back out to the parking lot. I started working on it Saturday with plans of having it all done by Sunday night, but I was on standby for work and ended up getting called out about 90 minutes after I started. The call was a few hours away, so I did not get the chance to do anymore work on Saturday. It took most of the day Sunday (minus a few other obligations) to get the rest of the lift on. I was working by myself and it took a lot longer than I expected. I'm methodical......

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC