Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > another issue...dashboard lights?

Join Wrangler Forum Today


Thread: another issue...dashboard lights? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-03-2010 09:43 PM
GrBeast001 I tried changing that fuse still nothing. any other suggestions?
03-03-2010 08:54 PM
NAVYCHIEF try fuse #10(tan) 5amp
03-03-2010 08:51 PM
GrBeast001 oh yea i good enough thump to knock some rust loose. ill try the cleaner. is there a fuse though?
03-03-2010 08:44 PM
AzTJ Did you give it a good thump?

Seriously. Get yourself some electrical cleaner and open that dash up. There might still be some moisture in the connectors or debris. Quite possibly it's just a bad bulb or two as well. Won't know until you open the dash.
03-03-2010 08:36 PM
GrBeast001 anybody?
03-03-2010 02:03 AM
GrBeast001
another issue...dashboard lights?

Hello All,

I have a problem with my 92 6cyl 5spd. It rained heavily last week here in ct and since my windshield cowel is shot water got into my dash and killed my dashboard lights. This happened once over the summer when it rained heavily but was fine once it dried but not this time.

What happened now is that the only lights that work on my dash is the cluster with the shift and high beam indicator right in the center above the steering wheel everything else wont light up. Also the back dome light stays lite all the time so I pulled the bulb.

Any help on how to resolve this issue would be greatly appreciated. i check for a fuse in the fuse box above the clutch but did see anything labeled dash.

Thanks again.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC