Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Ugh Clicking Turn Signal!

Join Wrangler Forum Today


Thread: Ugh Clicking Turn Signal! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-06-2010 05:53 PM
burton160w I actually just let it go and it finally cleared up after a week. What I actually did and what I think helped was found where the problem was. It's not in the turn signal box, it's not by the brake switch, but it's actually the hazard switch on top of the steering wheel malfunctioning.

Take the steering wheel surrounds apart. Easy to do.

Two screws on where that knee panel is underneath the steering wheel. Unscrew the metal shroud behind it. Use a flathead screwdriver to remove the long piece on top of the dash. Then remove the three screws that hold down the gauges. Pull out the gauges. Then there's three screws on the surrounding shroud underneath the steering wheel. Unscrew them (phillips head). Then jiggle out the top part. It's okay to disconnect that metal wire holding the steering height adjuster in. Unscrew the windshield wiper/turn signal arm (2 screws). Use WD-40 and then electrical contact cleaner vigorously and let it sit out overnight. Reinstall and you're done.

It's not as difficult as I made it sound. I simply pulled it apart by looking at it. Don't attempt to dissemble the wiper arm itself. Just spray vigorously around the hazard switch, and push the arm in all directions and spray with wd-40 (water repellent) then electrical cleaner.
03-28-2010 08:37 PM
vballspen did you ever get this sorted out i have now had the same issue after a soggy day in the rain topless
03-12-2010 10:38 PM
burton160w Update:

Well I went ahead and after reading a few other sites with cars that have the same problem, ran through the possibility of it being the hazard/turn signal control module (the stick itself). I disassembled the dash, removed the instrument panel then took away the two surrounding bezels. Removed the wiper/signal control module and used some WD-40 in both the male and female contacts. I'm letting it completely dry right now, and then tomorrow morning I'll go back and see the results. If it doesn't work, a salvage yard on my way up to school has the module for $16. I'll try a replacement and after that, if it keeps clicking, I'm selling the Jeep Hello CorollaForum.com

Also, I know WD-40 has a tendency to attract dust, therefore, in the long run can act as an insulator, but if it solves in for a little while, then at least I know where my problem lies.
03-12-2010 09:52 PM
burton160w
Ugh Clicking Turn Signal!

Okay, so I went wheeling the other day and ever since my turn signal intermittently clicks. I did get the cabin a little wet. It operates at normal rate if I engage the turn signal (left/right) or put on the flashers. And the intermittent clicks stop if I step on the brakes.

I've pulled the electronic T/S control module and dried it out.

I have also tested the ground wire and it checked out.

Thinking it odd that the brakes would cause the noise to cease, I pulled the cruise control module that connects to the brakes. The clicking continued (since the brake module was disconnected).

Now I've read other forums where it's a problem with the turn shifter/wiper module and contacts connecting. But I'm not convinced since why does it stop if I step on the brakes? My IDEA is that there possibly is a ground occurrence from the brake lights, since on my Cougar, if my cruise control module became disconnected my brake lights stayed on and if I stepped on the brakes my turn signal would go crazy because I had a powerful amp grounded to the same as my rear brake light.

Any suggestions, cause I'm at a loss and will be traveling back to school tomorrow.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC