Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 2000 wrangler oil guage stuck at 80

Join Wrangler Forum Today


Thread: 2000 wrangler oil guage stuck at 80 Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-18-2010 09:33 PM
Atthehop The oil pressure sender is just on top of the oil filter housing and points toward the firewall. You can see it easily if you look at the oil filter from above. It doesn't thread directly into the block, it threads into the oil filter housing.
03-18-2010 08:37 PM
ebeale thanks thanks thanks give me a clue as to where the sending unit is located. i will really appreciate it.

2000 wrangler mellow yellow black two piece hardtop by bestop auto i'm really starting to love this thing
03-18-2010 07:15 PM
Atthehop Did mine last year.
03-18-2010 06:34 PM
pokey Bad sending unit. Common problem, easy fix.
03-18-2010 05:46 PM
ebeale
2000 wrangler oil guage stuck at 80

2000 wrangler 4.0 automatic oil guage was working perfectly all of a sudden it now goes up to 80 and stays there, any ideas, the engine temp is normal and it doesn't seem to be starving for oil.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:59 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC