Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Ticking sound behind center dash

Join Wrangler Forum Today


Thread: Ticking sound behind center dash Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-28-2010 02:49 PM
mostlikely
Quote:
Originally Posted by knox View Post
I would actually check the grounds to the relays. If if was not getting power to actuate it, then it wouldnt click at all.
Thanks Knox.. As it turns out there is a small black box right below the steering column. There was a loose connection to that box and problem solved.....I have not found exactly what that box is yet, but I am assuming it is a relay as you said....
03-26-2010 10:57 PM
Samsrubicon hey most, i have the same noise, but mine happens when i turn the car off, if you have a cd player, start it up with a cd in it then when the noise starts eject the cd the noise should go away if its the same noise that i got.
03-26-2010 10:23 PM
Vanimal00000 Consult your local bomb tech! Sorry I just had to.
03-26-2010 09:56 PM
knox I would actually check the grounds to the relays. If if was not getting power to actuate it, then it wouldnt click at all.
03-26-2010 02:42 AM
desertdood
Quote:
Originally Posted by njkeagle View Post
Funny cause I have a chirping/whistling sound behind the radio. I believe it's when the heat is on but I am not sure.

Just pray to God that you don't have a pack rat back there. They're bad on Wrangler wiring down here.
03-25-2010 10:09 PM
mostlikely
Quote:
Originally Posted by njkeagle View Post
Funny cause I have a chirping/whistling sound behind the radio. I believe it's when the heat is on but I am not sure.
It's always something right! But I love solving problems.. I just read this on another thread about my Gauge cluster problem and will give it a try..

I had the same problem. All you have to do is take off the gauge cluster and clean the connections with q-tips and alcohol. Fixed the problem.

In older jeeps I have read that the heater blower can actually cause a fire because of , well I will just give you the link..

Jeep Fire Prevention, Jeep Fire Prevention - Retardant, Jp article, 4x4 article
03-25-2010 08:51 PM
njkeagle Funny cause I have a chirping/whistling sound behind the radio. I believe it's when the heat is on but I am not sure.
03-25-2010 08:25 PM
mostlikely
Quote:
Originally Posted by AzTJ View Post
^ I'd have to agree with knox. Start up relays for someting turning off an on. But I'm not positive.
Thanks and I agree with knox as well. I have also recently notice my instrument cluster malfunctioning at times. Sometimes the speedometer and tac stop working and then they are.. I removed that and noticed one of the two female adapters in the dash look kind of funky. So I am assuming it is a bad connection there causing that.
03-25-2010 08:14 PM
mostlikely
Quote:
Originally Posted by knox View Post
Mine does the same thing, but only at startup. It lasts about 1-2 seconds. I assume it is a relay, or a few relays inside the dash.
That does make sense! Unfortunately it continues for about 15, 20 minutes but then it stops. So, yeah that makes a lot of sense! Thanks... I am going to have to look deeper into that.. Basically I'm looking at a switch relay that could be anything from the turn signals to lights etc... I have noticed that my turn signal light comes on at times for no apparent reason... It must be electrical... I really appreciate your advice...
03-25-2010 06:20 PM
AzTJ ^ I'd have to agree with knox. Start up relays for someting turning off an on. But I'm not positive.
03-25-2010 11:21 AM
knox Mine does the same thing, but only at startup. It lasts about 1-2 seconds. I assume it is a relay, or a few relays inside the dash.
03-25-2010 10:54 AM
mostlikely
Ticking sound behind center dash

Good morning Jeepers!

I have a constant ticking noise in the center of my dash As soon as I start the engine. It clearly is coming from behind the radio. I removed center dash cover and pulled the radio. I put my hand on the center duct leading up to the windshield and can actually feel it ticking. I am assuming this is the defrost vent, but not sure? I tried the ac, thinking it was the fan making the noise, but it seems to have no relation to it... I am wondering if there is a separate fan for ventilation under center top dash cap grill, if that made any sense? If anyone has had this problem, or knows what is causing it, please reply as this noise is driving me nuts...

Thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC