Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Crazy knocking noise

Join Wrangler Forum Today


Thread: Crazy knocking noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-18-2010 01:48 AM
distortedtj If you still have the rear trac bar on...remove it with the lift bud.
04-18-2010 01:43 AM
mboomer Well, the noise is gone. I put the t-case drop in and that took care of it. Don't know what was hitting but it's all good now. Thanks everybody for the advice.
04-10-2010 03:07 PM
mboomer Gonna take the track bar out today and have another look at those motor mounts. Thanks for the info. I'll update when I'm done.
04-09-2010 02:33 PM
Garyk Usually with lift kits the rear track bar is removed...
04-08-2010 04:47 PM
benwillis
Rear Track Bar???

My performance 4X4 shop told me it was my rear track bar bushings (factory sealed of course). Haven't had time to replace it.
04-08-2010 03:23 PM
haroldpo6 Same noise on mine. Turned out to be the cat convertor. It had a big heavy chunk rolling around in it, took it off, noise gone. Runs so much better now..
04-08-2010 02:50 PM
Garyk Don't know what year yours is but on mine the drivers side is easy to check, rubber should be solid and not cracked and tight. One the passenger side the bottom of the motor mount bracket was broken on mine and from looking at it from topside you could not tell and even from underneath it was hard. Use a small pry bar, big screwdriver to check them.
04-08-2010 04:04 AM
mboomer what should i be looking for on the motor mounts? everything looks good from what i can see.
04-07-2010 02:57 AM
mboomer Gonna put the t-case drop in this week asap. No marks on the driveshaft at least that i can see. I was looking at the cover above the muffler, could that cause this noise? It's pretty thin metal and thats the only possible suspect.
04-06-2010 06:12 AM
Fweaky Do you have a transfercase drop installed? Do you see any marks on the rear driveshaft. It could be hitting the skid plate.
04-06-2010 04:15 AM
mboomer I just put new springs on the rear which lifted it two more inches. Total of 4 inches of lift and this made the noise happen more often. It just sounds like sheet metal banging away when I make a turn or accelerate. Still trying to get a closer look at the motor mounts though.
04-05-2010 01:38 PM
Garyk If the motor mounts check out, you might try checking the rear end. You might have broken the pin that sets in the plate the springs sit on on the rear end or you could have a broken spring etc.
04-05-2010 02:13 AM
mboomer Good looking out. I'll try it out and see if that's it. Thanks
04-05-2010 01:18 AM
Fweaky If you have someone with you its not hard to tell. Put the jeep in gear and hold the brake. Give it enough gas to make the engine torque against the mounts and see if the engine flexes up too much. The engine should flex in the mounts but still be held firm. On mine it broke the drivers side mount and was lifting hard against the mount on that side while the passenger side was stable. I have broken mounts a couple times over the years and I believe it has always been the drivers side on mine each time.
04-05-2010 01:03 AM
mboomer I'll have a look at the motor mounts in the morning. What should i be looking for. Hopefully it's pretty obvious. Or not.
04-05-2010 12:34 AM
Fweaky Even though your exhaust is solid it could still shift and bang against the frame or other parts if you have a broken motor mount. If the engine flexes to much when you apply torque it will bang usually around the transfer case skid plate area.
04-05-2010 12:07 AM
mboomer the exhaust seems pretty secure. I tried shaking it and moving it around and it doesnt seem to move. I'm gonna try and listen a little more carefully and see if that is what is making the noise. It sounds like its coming from the center more or less so I'm still stumped...
04-03-2010 08:23 PM
Pylonpounder If it DOES have that upsidedown u going over the trackbar, check to make sure the end of the tailpipe isn't hitting off the leaf springs, or the gas tank skid plate. (push it and see if you can get it to touch either one) Sometimes the hangers and such can go and allow this to happen. Mine was hitting the leaf spring. I wrapped one of those metal strips with holes in it around the exhaust pipe and used a self-taping sheet metal screw to screw it in to the gas tank skid plate (on the bottom, but about an inch away from where the tank itself starts) and that holds it away. It also has a make-shift hanger that holds it up in general as well, off the original hanger mount. it keeps it from banging.
04-03-2010 05:52 PM
mboomer Thanks I'll check it out and update.
04-03-2010 12:39 PM
hammer I agree about the tail pipe mine did the same thing. There
should be a large upside down U going over the rear axle
but most shops arnt used to that.
04-03-2010 12:12 PM
PaulyNC91YJ Check your tailpipe to see if its hitting the track bar. I had the same issue after getting a new muffler put on.
04-03-2010 11:25 AM
Snuffy115 Make sure the exhaust hanger by the transmission is in tact.
I had the same problem when mine rusted away.
04-02-2010 11:53 PM
Fweaky Check your motor mounts, exhaust hangers, transmission / transfer case mounts.
04-02-2010 11:49 PM
mboomer
Crazy knocking noise

Hopefully somebody can help me out here. Everytime I accelerate or make a left turn there is a crazy knocking noise coming from the rear right side of my YJ. I've heard it since I bought the Jeep and can't see anything wrong. It sounds like sheet metal is banging away on the underside. Any suggestions.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC