Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > motor bogging down on hard acceleration?

Join Wrangler Forum Today


Thread: motor bogging down on hard acceleration? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-11-2010 07:38 PM
89PBR96 I used Aeromotive on my Mustang
04-11-2010 07:21 PM
hotcash3 any suggestions?
04-10-2010 08:21 PM
hotcash3 Thank you, which regulator do you and others recommend?
04-10-2010 08:18 PM
scott howard yes you need a fuel regulator.
04-10-2010 08:02 PM
hotcash3
motor bogging down on hard acceleration?

I have a 1994 jeep yj that came with a 2.5 that was blown. I replaced it with a 1989 Chevy 350 TBI, np 205, and turbo 350. I Also Installed a painless wiring system. Upon normal or light acceleration it works fine, If I punch it bogs down. When it is idling it seems to run rich. Timing was adjusted and senors all replaced. Since I am unfamiliar with the TBI system my question is The TBI takes 11-15PSI and I believe the jeeps fuel pump is putting out 30-35psi. Will this cause these issues and will an in line fuel regulator fix the problem?
thank you so much for your response and help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC