Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 94 Electrical Problem

Join Wrangler Forum Today


Thread: 94 Electrical Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-01-2010 02:42 PM
Vaultzz You might have overloaded a wire somehow and it cut the line. Time to take the dash apart and start following wires, or have a mechanic do it
05-01-2010 02:39 PM
Garyk I would guess a bad wire or connection
05-01-2010 03:20 AM
Captainframe
94 Electrical Problem

I have a slight problem, I notice that my dash lights were not operating so I pulled the dimmer and cleaned all the connections. I put everything back together and still nothing. I then pulled the insturment clusters and cleand it and still nothing. Than tonight I noticed my parking lights are not operating. This just happened because they were operating correctly. I checked under the dash and notice one of my fuses were blown(ACCLights 5 amp fuse). I replaced it and still nothing. Is my switch and dimmer bad or what. The headlights come on, the tun signals work and the brake lights work. No running, park or dash lights.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC