Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 2.5 engine replacement now no spark or check engine light

Join Wrangler Forum Today


Thread: 2.5 engine replacement now no spark or check engine light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-23-2012 10:53 PM
dant07123 I'm having the same problem my 94 motor had a blown head gasket so I swap it with the same 2.5 liter motor out of a 93 and I have no spark and the fuel pump is not working i have checked every wire and fuse and can't figure out what the problem is
05-06-2010 01:37 PM
tdfeickert Questions Related to this post:
1) Are the computers interchangeable between 1993 and 1994 for same configuration jeep?
2) How else do I trouble shoot to figure out if computer is bad? I'm about to just send it off to be rebuilt from a place online that does computers. Before I do that, I want to make sure it really is bad. Since it ran without issue before the swap, it should still be good.
3) Are the main engine harnesses interchangeable from 1993 to 1994 2.5? Everything seems to be the same?

I just can't figure out what I'm missing on this one!!!!
05-06-2010 01:14 PM
tdfeickert
2.5 engine replacement now no spark or check engine light

I bought the Jeep with 90k miles on it and a motor with a bad rod and major engine noise. The engine ran and drove but very loudly and dangerously. The only reason I state that is that I know the computer and all components were fine because it would start right up, run, and drive...just made a LOT of racket.

I bought a used motor from a guy who was about to do an engine swap to a 4.3 conversion. I heard his 1993 motor run. I helped him pull the motor and I took it to my place to replace my 1994 2.5. I just did the swap of the 1993 YJ 2.5 into my 1994 YJ that had a 2.5. After making the switch, I don't have any check engine light and I don't have an power to the starter. If I bypass the relays and give power from the ignition switch to the starter, I don't get any fire at the coil so there's obviously a computer or crank position sensor issue. I put in a new CPS but no change. I swapped computers so I put the 1993 computer in...again, no change. One of my questions is if I changed out the engine (should be identical), do I need to change out the computer to match it or does the computer match the vehicle more than the engine? The sensors all seemed to line up with the engine wiring harness. The vehicles were the same config (2.5 w/ manual transmission and no options...both S models) so this should have been an easy swap. Help!

I get the battery light when I turn the key ahead to the start position, but I have no check engine light when the key is in any position. When I try this without any computer or CPS in the vehicle, I get the exact same symptoms. I can trouble-shoot with the best of them but this is killing me. For what should have been a 4-6 hour engine swap and go, this has consumed several days of my time.

Any help would be highly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC