Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 2000 tj TRACK BAR TIE ROD MOVEMENT

Join Wrangler Forum Today


Thread: 2000 tj TRACK BAR TIE ROD MOVEMENT Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-15-2010 06:03 AM
ebeale Thanks i guess i will try to tighten the tie rod first if not i will replace the ends. The bar is not bent or damaged
05-14-2010 04:13 PM
jwm1986 Might get away with tightening the track bar mounts... On the tie rod, you may need to replace the end links. Then, check your alignment.
05-14-2010 02:48 PM
ebeale Do i replace just the ends or the complete assemblies. The jeep is bone stock. Also where can i get the parts at a reasonable price. I am quite handy is this a job i can do myself. I have quite a few tools. I replaced the radiator and o/p sending unit myself.
05-14-2010 02:36 PM
doclouie You should have no play in either. Time for some new parts.
05-14-2010 02:31 PM
ebeale
2000 tj TRACK BAR TIE ROD MOVEMENT

Thanks in advance i have a 2000 tj with 73000 miles i have a small click in the front end when i turn the wheels left or right. I grabbed a hold of the track bar and i can move it up and down about 1/2" the same with the tie rod. Should they be tight or is some play acceptable. I just purchased the jeep and this is the only problem i haven't repaired. Already changed the radiator o/p sending unit. All else is fine. Thanks by the way no one in miami fl waves

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:23 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC