Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Electrical Nightmare!

Join Wrangler Forum Today


Thread: Electrical Nightmare! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-22-2010 09:39 AM
deathphoenix99 As for the dash reading 19 volts, dash gauges are known to be horrbly inacurate, I suggest you check the voltage at the battery when the jeep is running, if it is 19 volts, TURN IT OFF IMMEDIATLEY. That high of a voltage will do damage to your electronics. If it is that high, then the voltage regulator on the alternator is bad. I believe it's built into the alternator and is not replaceable, meaning you will have to replace the alternator.
05-22-2010 05:56 AM
Lowrollin12
Quote:
Originally Posted by pokey View Post
Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.
thanks for the help!
05-21-2010 03:39 PM
pokey Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.
05-21-2010 02:44 PM
Lowrollin12 No the voltage on the guage cluster is reading that... Im not saying that is what it really is but something is going on...
05-21-2010 01:37 PM
meyers The voltage is 19volts at the dash? How are you checking this voltage, the battery is only 12 volts. You may get 14 - 14.5 when charging. But 19 is way out of spec.
05-21-2010 08:57 AM
Lowrollin12
Electrical Nightmare!

So 1st I thought i was having issues with the ignition switch when I would have the air bag light come on, No wipers, no radio and no heat. Then it would 1/2 resolve itself and i just wouldnt have wipers and couldnt use the fan on high....

Now the jeep wont start with out a jump and the voltage is around 19 volts on the dash....

I think this could all be from the ignition switch but what do you think?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:20 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC