Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Center Console Vent - no blow

Join Wrangler Forum Today


Thread: Center Console Vent - no blow Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-24-2010 10:41 PM
speed_phreak
Quote:
Originally Posted by QADaemon View Post
Most likely a leak; might not even have to get under the dash; the most common one is the t-fitting leading inside the cab from the engine compartment.
Thank you sir! I looked under the hood and the damn vacuum line wasn't even connected to the intake manifold!!! It was just hanging along the firewall collecting dirt. I connected it and fired up the Jeep, turned on the center console vents and out came a plume of dust.... LOL..

I thought it ran fine before, but that was a pretty major vacuum leak, can't wait to see how much better she responds on the drive to work tomorrow!

Thanks again for pointing me in the right direction!
05-23-2010 06:41 AM
Kate Thank you QAD. We checked the tank, don't know about the check valve. Will certainly look into it.

It's one of those intermittant things that you forget about until you realize that you feet are cooking or your forehead is frozen
05-23-2010 06:30 AM
QADaemon Most likely a leak; might not even have to get under the dash; the most common one is the t-fitting leading inside the cab from the engine compartment.

Kate, your problem might be the check valve leading to the vacuum reserve tank, or the tank itself.
05-23-2010 05:18 AM
Kate Start by checking all of your vacuum lines.
Begin at the firewall and work your way around. There are a number of places where these can crack.

Mine does it, strangely ONLY when I'm travelling down the highway. It will refuse to change from floor to defrost to whatever unless I reduce my speed, thereby changing the vacuum pressure on my system.

I've checked my vacuum lines, and rechecked. Still have not found the leak.
Sooner or later it will either break completely or I will get frustrated and start ripping things out by the roots and replacing at random.
05-23-2010 03:25 AM
solman My is doing the same thing. I hope someone has an answer. I haven't had a chance to check it out yet.
05-22-2010 11:55 PM
speed_phreak
Center Console Vent - no blow

Hello all,

Just bought a 2005 TJ Rocky Mountain. I test drove some JK's and they are nice, but I wanted a Jeep...

Anyways, on my way home from the dealership, I noticed that the vents in the center console don't blow and the defroster is always on. How is that switch supposed to be actuated? Vacuum?

How hard is it to pull out the dash in these things?

TIA

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:03 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC