Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > Radio Wont play music just loud noise

Join Wrangler Forum Today


Thread: Radio Wont play music just loud noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-24-2010 03:22 PM
sevenservices sounds like two wires are touching behind a speaker. Did you change speakers or move anything that would have moved something behind 'em?

Or possibly have water leaking in behind a speaker??? They'll make that horrible noise when the + and - speaker wires touch.
05-24-2010 03:16 PM
baja
Quote:
Originally Posted by JIMBOX View Post
Probably just RAP music !!

JIMBO
Beat me to it!
05-15-2010 08:20 PM
JIMBOX Probably just RAP music !!

JIMBO
05-15-2010 08:09 PM
Jma20a is it a factory unit?
05-15-2010 02:31 PM
RoSs
Radio Wont play music just loud noise

So the other day i was crusin down the road and my radio just started squealing and buzzing!!!! Now sometimes when u turn it on u can kinda hear music but for the most part it just make that horrible noise. Not sure what the deal is, maybe a loose connection behind the radio or something. Any ideas would be great help. Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:15 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC