Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Lift Install Questions

Join Wrangler Forum Today


Thread: Lift Install Questions Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-27-2007 05:54 AM
stevin33 awesome..!!!!!
glad it worked out for ya.
can't wait to see the pics
03-26-2007 09:34 PM
Adventurous Just wanted to post an update. I installed the rear lift this weekend and the problem corrected itself. Thanks for all the advice.
03-16-2007 04:25 PM
Adventurous He didn't add a bumpstop under the original one. It is the lip of the bumpstop that's hitting it. I'll get some pics up as soon as I can...the roads are pretty bad right now and I can't get out there to take one.
03-16-2007 04:15 PM
Stouttrout Usually on a lift without adjustable control arms the wheelbase will become short. the tire in front and back are "squezed" togehter. On a 2" you should not have this problem but they are close anyway. Check your Cam bolt on the lowers to make sure they are in the right spot. Did he add a bumpstop up under the original bumpstop mount? Is it the lip of the bumpstop hitting the spring? Can you post up a pic in any way?
03-16-2007 02:34 PM
Adventurous It was on the ground with all 4 tires on.
03-16-2007 08:54 AM
mrbigjeep
Quote:
Originally Posted by offroadpatrol View Post
"The lower spring retainer clamps are missing. Are they necessary?"

WOW!...glad I read this...for the spring clamp link...my jeep doesn't have any at all...[/QUOTE]

mine doesn't have any either. who needs em?
03-16-2007 08:52 AM
mrbigjeep does he have the front off jackstands and sitting on the ground with wheels/tires on? if he still has it on jackstands then i would expect the spring to be hitting the bumpstops because the axle isn't jacked up. we had the axle on jackstands and my spring hit the bumpstop too untill i jacked it back up and put the tires/wheels on.
03-16-2007 07:14 AM
Adventurous It's only a 2" lift.
03-16-2007 12:47 AM
1BLKJP If you are using stock springs or small lift springs then those spring retainer clips are not necessary as the shocks will not let it droop enough to completely lose the spring. Especially if you put extended bumpstops in it.

As for the springs hitting the bumpstop. How much lift are they? Could be the axle not centered due to trac bar. Could just not be completely seated in the cup some. All TJ's springs are closer to the bumpstops in the front with lift springs. But they should not be touching.
03-16-2007 12:34 AM
offroadpatrol "The lower spring retainer clamps are missing. Are they necessary?"[/QUOTE]


WOW!...glad I read this...for the spring clamp link...my jeep doesn't have any at all...
03-15-2007 11:50 PM
binaryking
Quote:
Originally Posted by Adventurous View Post
...It was the drivers side that had the spring retainer. Is it not needed on the passenger side?
You need one for the passenger side too, or else in full flex you could lose a coil spring. I've seen it happen. Rusty's off road carries them.

http://rustysoffroad.com/mm5/merchan...ory_Code=COILS

It isn't something that you HAVE to add right now, but I would get one.
03-15-2007 09:51 PM
4Jeepn They should not be touching, something would seem to be off with the axle perhaps. Did he remove the control arms? As for the bracket yes, only the driver's side has it, not sure why.
03-15-2007 09:17 PM
Adventurous I don't have pics...I stopped by to see it after work. Yes, the bumpstop hang down bracket is contacting the spring.

It was the drivers side that had the spring retainer. Is it not needed on the passenger side?
03-15-2007 09:13 PM
4Jeepn Got pic's of the spring? Are you saying the bumpstop hang down bracket is contacting the spring or is it something else?

Most jeeps only have the spring retainer on the driver's side.. you should be able to pick these up at the dealer.
03-15-2007 08:46 PM
Adventurous
Lift Install Questions

So, I purchased the OME Stage 1 Lift and my father offered to install it for me. He started work on the front first and has a couple of questions before moving to the rear. They are:

"After installing new longer coil springs, the upper spring guide posts rub the forward inner part of the spring. How is this prevented?" Keep in mind he has only done the front. Will this be corrected once the rear lift is installed?

"The lower spring retainer clamps are missing. Are they necessary?"

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:20 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC