Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Misfiring Question

Join Wrangler Forum Today


Thread: Misfiring Question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-16-2010 05:27 PM
Indy I think your TPS might be going bad. Does it still sound like that at higher RPMs? If not, then you it should be safe to drive it around.
06-16-2010 04:59 PM
Mclaughlin_1234
Misfiring Question

Alright this is gonna be a long one...Please read

So the past couple mornings ive been getting up for work and when i start up my 2004 I6 it would be very rough, But as soon as i touch the gas it would go back to normal with a little choppyness. So when im driving its fine. So this morning i get up and the check engine light is on, So i pull the code and it says im missfiring out of my 6th cylinder.So i imedatly drive to autozone buy plugs,gaped them perfectly and then put it in. Now i start up my jeep and it starts right up but the engine light is on,Now im thinking to my self crap forgot to disconect the battery,so i do that and the light obv goes away,ive driven about 20 miles now and it hasnt come back on,but my rpms are fine when im at a stop but my exhaust sounds like i have an agressive came in it or something,What should i do,should i stop driving it? sorry for my spelling!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC