Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > High Idle

Join Wrangler Forum Today


Thread: High Idle Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-18-2010 12:21 AM
JeeperRob Can some one with an early model YJ that has the 4cyl AMC 150 take a look and see what vacuum hose goes to that nipple?
06-17-2010 03:52 PM
JeeperRob I looked around a found a nipple off the intake that didnt have a hose on it but couldn't find a lose hose any where. I took a picture of it. Does anyone know where the hose that hooks up to this nipple goes?
06-17-2010 03:26 PM
Got_Mud? I don't know if his Jeep has one, but my old truck has a monster vacuum line to the master brake cylinder and it comes from the manifold - when it got cracked it caused a horribly high idle... and it's a big hose, too.....
06-17-2010 03:10 PM
JeeperRob Yea my thoughts too. Are there any lines specifically to check that would cause this high idle?
06-17-2010 03:06 PM
flatline vacuum leak?
06-17-2010 02:52 PM
JeeperRob
High Idle

I just replaced my exhaust manifold on my 89 with 2.5L engine because it was cracked. In order to do this I had to remove my intake manifold and Throttle body. After putting everything back together I started the Jeep and am having a high idle (3000 RPMs). Any Idea what I could have do to cause this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC