Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Fuel Pump problem - help!

Join Wrangler Forum Today


Thread: Fuel Pump problem - help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-29-2010 07:41 AM
dmw319 yea yea the JEEP i mean.
07-28-2010 10:27 PM
wyomeeks I think you hurt your "JEEP'S" feelings and won't run because you call it a "CAR''.... Maybe try calling it a jeep and it might run for you???? Just a thought? lol
07-28-2010 02:17 PM
dmw319 bump. car still isnt fixed. anyone with any more ideas?
07-08-2010 04:20 PM
dmw319 also, i mean MAP not MAF, sorry. BUMP!
07-08-2010 08:43 AM
dmw319 here is a picture: Lauren's new jeep! on Twitpic
07-07-2010 10:41 PM
dmw319 anyway, UPDATE:

We checked the fuel pressure and it was fine.. so we were able to start the car no problem and have it sit in the garage and it would run with no issues other than an occasional hiccup during idle, but kept running. revved it, let it sit, started right back up again, so we took it for a test drive. got about 1 minute down the road and the car died again. We unplugged the IAC and no change. Then unplugged the MAF and the car started right up and ran fine and then we drove it 15 minutes without any issues. Think it could be the MAF? Kinda strange how I don't think it has anything to do with fuel anymore.. I guess tomorrow we can test a MAF once a part store is open..
07-07-2010 03:14 PM
dmw319 measurement of tank? tell from something else on the vehicle? etc. I have just seen a lot of parts stores online that keep asking for 15 or 19 gallon tank size when looking at fuel pump assemblies and such, just trying to see if there is any other way to find out than the obvious way haha.
07-07-2010 03:06 PM
dmw319 haha well that would work if the car worked well enough to drive around haha.
07-07-2010 03:03 PM
Jerry Bransford Uh, carry a gallon container of gasoline and then drive it until it runs out? Then you can refill it and know for sure. The gauge will show empty even when there are 1-4 gallons left in the tank so don't use the gauge as the indicator. My way-off gas gauge shows empty now when there are close to ten gallons left in the tank.
07-07-2010 02:57 PM
dmw319 hmm. is there any way to find out?
07-07-2010 02:53 PM
Jerry Bransford
Quote:
Originally Posted by dmw319 View Post
question - how do you know if you have a 15 or 19 gallon tank?
That's hard to say but most TJs came with the 19 gallon tank. Only the really stripped down models came with the 15 gallon tank.
07-07-2010 02:50 PM
dmw319 question - how do you know if you have a 15 or 19 gallon tank?
07-07-2010 01:49 PM
dmw319 Haha, I can see that. Sorry guys, it won't happen again! Today is my first day owning a Jeep
07-07-2010 01:48 PM
Jerry Bransford Yes our Jeeps are OBDII. I suggest not calling your Jeep a "car" as they (and most Jeep owners) are very sensitive about such things.
07-07-2010 01:43 PM
dmw319 yea, that makes sense. When I get home around 6 I will try and get it going again and post back up. are these cars obd2? I could use a scanner to pull some codes, if it has any. which ones would I be looking for that would point to one of the sensors being bad?
07-07-2010 01:34 PM
Jerry Bransford Slow start = it takes a lot of cranking time for the engine to actually start when the fuel pressure regulator has gone bad. They get leaky when they go bad and let the fuel drain down out of the engine and back into the fuel tank... hence the slow start.
07-07-2010 01:31 PM
dmw319 what do you mean when you say "slow starts"? I haven't honestly spent enough time with the car to give an accurate description of the problem, I am just trying to get as much info about what could be wrong while im at work so I can get working on it when I get home.
07-07-2010 01:23 PM
Jerry Bransford It's not the fuel pressure regulator because when they go bad, they don't stop the flow of fuel like the fuel pump underneath it can. When the fuel pressure regulator goes bad, it normally just causes very slow starts but once the engine is running, it's fine.

Yes pretty much any auto parts store can get those sensors if they don't have them in stock. BUT where sensors are concerned, I prefer the OE sensors as some of the aftermarket sensors are very poor quality. Some websites like RockAuto Auto Parts often sell OE sensors for a lot less than the dealer will.
07-07-2010 01:14 PM
A_Mason Based on your description what you bought defintely is not a "car". You might take it to Autozone if you can get it there and have them check your diagnostic codes. They will do it for free and it might give you some hints about where to start.
07-07-2010 01:08 PM
dmw319 thanks Jerry! what makes you think it isnt the regulator? or pump? the guy i bought it from said that he had taken it to a shop and thats what they told him (although, i dont know the validity of the shop)

i had read this post before posting (which is why i was asking):
http://www.wranglerforum.com/f5/2000...ent-45552.html

I will check into those sensors. are those sensors I could buy at any auto parts store and swap out real quick to see if the problem is fixed? could i possibly check the fuel pressure to help diagnose the problem? thanks again in advance.

a little more about the car also.. its intense blue, fresh motor (less than 500 miles on it), 76,000 on body, 33 inch bfgoodrich all-terrains. new exhaust, bestop, PIAA lights, detroit locker front and back, 3.5 inch suspension and body lift. i hope to get pics up soon!
07-07-2010 12:59 PM
Jerry Bransford While that problem COULD be from a bad fuel pump, it may not be and it's definitely not the fuel pressure regulator causing that problem. The engine computer is what turns the fuel pump on and off and if the engine computer is not happy with what all the sensors are telling it, it will shut the fuel pump off via the ASD (auto shutdown) relay.

I'd start looking at the two most likely sensors that can cause this type of problem. First being the Crankshaft Position Sensor that generates the engine's master timing signal. It is mounted up high on the driver's side where the transmission bolts to the engine. When it goes bad, the engine will stall/quit which can happen intermittently. The second sensor is less likely to go bad but when it does, it causes the same problem. This one is the Camshaft Position Sensor which is mounted underneath the distributor cap, under the rotor.

Those two sensors would be high on my list of possiblities. And a big welcome to WF.
07-07-2010 12:39 PM
dmw319
Fuel Pump problem - help!

Hey everyone. Newbie here. My name is Dave I just bought a 99 wrangler 2.5L. I bought the car from the owner who said the fuel pump needed to be replaced. He had the car sitting for about 2 months, but the day we bought it he went and took it to the gas station to fill it up. When test driving the car, it started up just fine but then when we were driving it it stalled and we couldnt get it to crank back up. However when it got towed to my house this morning the tow truck driver backed it up off the flatbed and drove it right into my garage no problem.

I have searched/read on here that it may be the fuel pressure regulator on top of the pump that needs to be fixed, or maybe i need to replace the whole pump? Any ideas on how to best diagnose the problem before I buy any parts and drop the tank? We really need to get it fixed tonight if possible - I've got plenty of tools and friends to help. haha. Thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC