Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > I have an unknown clutch problem... Please Help

Join Wrangler Forum Today


Thread: I have an unknown clutch problem... Please Help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-21-2010 05:07 PM
scott howard It could also be as simple as the push rod came off the clutch pedal .
get up under the dash and take a look.
07-21-2010 01:49 AM
FNjeep That's a poorly adjusted clutch cable (too tight). You might have broken off one of the clutch finger splines when pushing into the pedal to the floor.

That's an installation issue, and not your fault (or a faulty clutch plate cover). Still not your fault.

I hope you kept your receipts. Take your Jeep back to where you had the work done. The shop should pay for the replacement parts for the clutch - unfortunately, they probably wont eat the labor costs unless they offered some sort of guarantee.
07-20-2010 12:13 PM
flatline think I would start with the clutch master cylinder and check the rod that conects to the clutch pedal and pushes into the master cylinder.
07-20-2010 11:45 AM
91orangejeep
I have an unknown clutch problem... Please Help

Hello fellow Jeep owners!

I am new to this website because am a fairly new Jeep owner. I have a '91 YJ.

I recently had the clutch replaced and it has been working perfectly for many months. The other day I was stopped at a guard gate and and had the clutch pressed down while i was waiting (even though it was in neutral). When the guard asked me for my license I reached in my back pocket and gave it to him. When I reached in my pocket I put a large amount of weight on the clutch. So much that it felt like something snapped. Now there is no tension in the clutch at all. It is completely dead. When the engine is off I can still put the jeep in gear. Just no use of the clutch.

I know that it is all hydraulic based but other than that I have no idea. It really sounded like there is a tension line that snapped and that's what I thought it was, but I think that is wrong.

Anyways, any help will be much appreciated. Thanks,
Greg

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC