Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > hiccup

Join Wrangler Forum Today


Thread: hiccup Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-24-2013 12:31 PM
XTRyan
Quote:
Originally Posted by zbrown62 View Post
so my jeep starts fine and there are no smells and there are no noises while i drive it but when i come to a top it will die if i dont rev the engine and when im accelerating the engine hiccups. i checked the engine and there is nothing out of place or anything like that and there are no leaks. also the check engine light is on. does anyone have any ideas as to whats going on?
Step one is to read the code. Go to an Advance Auto somewhere similar that will plug it in and read the code for you for free. Then you'll have a good starting point to advice.

Let me know if you have any questions!

-Ryan
12-24-2013 12:24 PM
zbrown62
hiccup

so my jeep starts fine and there are no smells and there are no noises while i drive it but when i come to a top it will die if i dont rev the engine and when im accelerating the engine hiccups. i checked the engine and there is nothing out of place or anything like that and there are no leaks. also the check engine light is on. does anyone have any ideas as to whats going on?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC