Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Fuel pump again??

Join Wrangler Forum Today


Thread: Fuel pump again?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-27-2010 04:10 PM
Drummer_192 I finally got the new coil plugged in today, i didnt bolt it down just in case it didnt work, and sure enough theres still no fire. Whats the next step???
07-19-2010 05:32 PM
flatline probably something else. check fuel rail presure. you can get cheap tester at harbour freight, it's not great but it works for $29. next I would check codes, then spark. crank with no fire usually a coil or crank sensor. had mine just shut off, just a bad coil.
07-19-2010 05:23 PM
Drummer_192
Fuel pump again??

So about a month a half ago my fuel pump went out on the way to work, took it home replaced it, still nothing, then we found that a fuse was burnt under the hood, replaced it and it fired right up.

Now today im headed home from work, pull into town, and it dies on me again. Just like last time, no pops, bangs just dies and will turn over and turn over but no fire. Doesnt even attempt. I can hear the fuel pump humming when i turn the key, and the fuse is fine but still nothing.

Does anyone have some advice on if it the fuel pump again or could be something else????

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC