Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Engine runs very rough in morning.

Join Wrangler Forum Today


Thread: Engine runs very rough in morning. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-30-2010 06:46 AM
StinkyMud
Quote:
Originally Posted by rrich View Post
The O2 sensors really don't do anything the first 2 minutes -= it's still in open loop.
Rough before it goes into closed loop is most often a vacuum leak somewhere. Once it's in closed loop it compensates for the leak.

Check all vacuum lines, check the manifold gaskets. Spray around a burnable carb cleaner to find the leak. Or use propane.
X2, well said.
07-29-2010 09:41 PM
rrich The O2 sensors really don't do anything the first 2 minutes -= it's still in open loop.
Rough before it goes into closed loop is most often a vacuum leak somewhere. Once it's in closed loop it compensates for the leak.

Check all vacuum lines, check the manifold gaskets. Spray around a burnable carb cleaner to find the leak. Or use propane.
07-29-2010 06:32 PM
flatline x2 on the tune up. sounds like it's missing. or, does it smell like it's running rich?
07-29-2010 06:00 PM
Indy When was the last time you did a tune up?
07-29-2010 01:51 PM
TheDudeAbides
Engine runs very rough in morning.

Hey guys, I've had this problem for a month or two now. After leaving my jeep parked overnight or for an extended period of time 8 hours or so, after starting it up it runs very rough for about 2 minutes and then it smooths out and runs fine. I've replaced my upstream o2 sensor and cleaned my IAC and that didn't help it. Anyways I uploaded a video to youtube where you can actually hear my problem. YouTube - Rough start jeep please take the time to watch just the first 30 seconds to hear my problem and let me know what you think it could be. I have a 1997 Jeep wrangler TJ with an automatic transmission. Any help is greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC