Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Vampire drain on 95 wrangler

Join Wrangler Forum Today


Thread: Vampire drain on 95 wrangler Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-03-2010 10:46 PM
Wrangler Haven Sometimes the ignition switch under the dash (not the lock cylinder in the steering column) can go bad and cause a slow drain.
With the engine off, remove the starter relay from the power distribution center under the hood. Hook up your amp meter to the battery then have a friend cycle the ignition key forward and back a few times and see if you get a spike on the amp meter.
08-03-2010 02:52 PM
kj 92yj any chance there is some aftermarket stereo or lighting equipment that are hooked to constant power without being hooked up to an on/off fuse or switch?
08-03-2010 11:28 AM
southernpryed Thanks JDsDREAM I checked all the grounds evrything is tight and all conecters are in good shape. Terminals are corrosion free. That kinda of amp drain Im thinking it might
be in a main wire harness I just hate to break stuff loose not knowing where it is coming from. Thanks again for the help and I will let you know how it turns out.
08-02-2010 08:22 AM
JDsDream Have you checked for any loose grounds? You may also want to make sure that your battery connections are clean and secure. Disconnect them and clean them thoroughly with a wire brush. Any amount of corrosion will cause the system to drain. Once reconnected, make sure they are tight. You should not be able to turn or twist the cables at the connectors. Also check for any cracks, breaks or hot spots on the cables. It could be something entirely different, but always start with the easiest/cheapest first.
08-02-2010 07:24 AM
southernpryed
Vampire drain on 95 wrangler

I have a 95 jeep wrangler 4 cylinder I have only had it about 2 months. Last week the battery went dead it was old so I replaced it worked fine for a week and dead again. I figured it was the alternator so I took to advanced and had it tested. The alternator and starter were fine but the drain test showed a 32.9 amp drain. I was hoping someone may have had a similar problem and has a quick fix. If not I am going to hook a amp meter to the fuse line and start pulling fuses to see if I can isolate it that way. If anyone knows where I can find a wiring diagram with amperages that would be a great help as well. THANKS FOR YOUR TIME

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC