Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum > 2012 Wrangler sport radiator

Join Wrangler Forum Today


Thread: 2012 Wrangler sport radiator Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-03-2014 10:30 PM
CharlesS In 2012 the transmission cooler was moved upward which places the cooler more in the air flow. This keeps the transmission fluid cooler during heavy use.
The 2007-2011 transmission coolers were lower out of the main air flow which caused the fluid to over heat under heavy loads. You would see an "OIL TEMP" alarm displayed on the instrument cluster.
01-03-2014 06:58 PM
Paprika Can anyone else confirm? Thanks
12-27-2013 04:46 PM
Paprika I have a manual transmission...thank you for replying
12-27-2013 04:24 PM
bengen1 You have a manual or auto? Without looking at mine I would guess it's auto trans cooling lines?
12-27-2013 03:41 PM
Paprika
2012 Wrangler sport radiator

Have a question. I was lloking at the front of the jeep the other day and noticed that when i looked through the grill at the radiator that there appeared to be something missing on the right side. There is a plastic bracket with two screw holes that look like there should be something attatched to it but, there isnt.

I looked at a jeep sport at the dealership and on that jeep there are two steel tubes attached to the bracket, where on mine those tubes are not there?

Any ideas? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC