Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > rear shock replacement - upper mounting brackets

Join Wrangler Forum Today


Thread: rear shock replacement - upper mounting brackets Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-18-2010 10:57 PM
dmetzler Some more PB Blaster and a good soak and I was able to free the final bolt on the rear driver's side and get the old top bracket out. Woohoo!

Thanks again for the suggestions!

Don
08-15-2010 10:23 PM
dmetzler The passenger side bracket is now off! The driver's side is being a bit more difficult, but another shot of PB Blaster and waiting for it to soak in...

Thanks for the suggestions - they have been a *big* help!

Don
08-15-2010 04:46 PM
dmetzler Thanks for the suggestions. I have not tried working the bracket out yet, as I was hoping to get the new shocks on the existing brackets. Will give that a shot, as well as the 13mm wrench. There is more room to maneuver now that the old shocks are out.

I have avoided the torch/heat method being so close to the gas tank.

Will keep you posted...

Thanks,

Don
08-15-2010 04:41 PM
Tarby I get what your saying...If I remember when I put my wife's skyjackers on, the brackets are a little different than the ones that were on the old shocks that I removed. The poly bushings might not "sit" correctly on the old mount brackets. I would remove the old hardware and use the new, and when you put the bolts back in, anti-seize the snot out of those bolts. I actually put stainless ones in place of the old ones to save on corrosion.
08-15-2010 04:37 PM
Ted_D try a 13 mm socket
08-15-2010 04:36 PM
Jerry Bransford I know that bolt is still tight but have you tried working the bar pin back & forth to see if you can work it out from under the bolt head? If you can do that, perhaps you can get it out with the combo wrench. Heat can help to loosen bolts like that too, like from a torch or propane torch.
08-15-2010 04:30 PM
dmetzler Yeah - sorry, my initial post was a bit wordy.

Basically the top brackets are still connected with one bolt (see photo). I can get the grommet on the bracket, but if I put the grommet in the shock and try to push it on the bracket, the grommet always slips off.

Should be a simple problem to solve at this point, or so I thought.



Thanks for the help.

Don
08-15-2010 03:42 PM
burton160w Would you mind taking a picture of what you're talking about. Or, steal some pictures from this thread (the OP is a jackass anyway) and just circle what part you're talking about. I can help you from there. I'm just confused about the wording because I'm a little slow.

08-15-2010 11:43 AM
dmetzler
rear shock replacement - upper mounting brackets

Hi All,

I have read some threads here about the pain associated with replacing rear shocks, but decided to give it a go anyway.

Most of the job has not been too bad, except for the two outside bolts on the top mounts. I have used PB Blaster many times, let them soak for hours, but cannot crack the bolts off. Tried tightening, loosening - using a 1/2" socket on a 1/2" breaker bar - nothing. Problem is the socket always slips on the bolt head, even though the bolt head is not stripped. I can get a box wrench on the bolt, but have no room or leverage to move the wrench once in position.

In a moment of desperation I got a pry bar and used it to slide the shocks off the upper mounting bracket by pulling and prying the shocks out. Aside from the upper mounting brackets bending down a bit, it got the job done - the old shocks are removed, with their top mounting brackets still in place.

I am now attempting to install the new shocks (Skyjacker Nitro 8000s). The upper mounting grommets are in the top of the new shocks. When I attempt to slide them over the upper mounting brackets, of course, the grommet slides onto the bracket and out of the shock. There is not enough leverage to put the grommet on the bracket first and then pull the shock on to the grommet.

Am I better off trying to get the new shocks on the existing upper brackets, or attempt to get the old bolts/brackets out and then install the new shocks/brackets? This would at least have the new shock ready to mount without dealing with getting the shock mounted on the old bracket. Any suggestions?

Thanks for the help,

Don

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:33 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC