Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In > Repetitive clicking/thumping noise when accelerating coming under driver seat/t-case

Join Wrangler Forum Today


Thread: Repetitive clicking/thumping noise when accelerating coming under driver seat/t-case Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-21-2010 02:18 PM
Clarence1 will do thanks!
08-21-2010 01:11 PM
stangfreak welcome, start a thread in the tech forum
08-21-2010 10:39 AM
KBR97 Get underneath there and look/feel around, could be a broken linkage, a wire that came loose and the plug is clanking around, maybe a bad u-joint, maybe even something as simple as a stick that got jammed up there and now fell out since you say it stopped.

Welcome to the forum BTW
08-21-2010 09:31 AM
Clarence1
Repetitive clicking/thumping noise when accelerating coming under driver seat/t-case

I have a 98 Wrangler and itís making repetitive loud clicking/thumping noise when accelerating coming from under driver seat/t-case area. This noise gets louder as accelerating and quiets down when in neutral. The strange thing is that it sat over night and now itís not making any noise. Could it be a T-Case linkage issue/or a bad torque shaft bushing? I just donít understand how such a noise can just go away? Thanks.


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:00 AM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC