Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > ZJ Tie Rod and TJ Drag link Question

Join Wrangler Forum Today


Thread: ZJ Tie Rod and TJ Drag link Question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-25-2010 09:30 AM
jeepjones
Quote:
Originally Posted by 47MTP View Post
ZJ tie rod will fit just fine. The drag link is exactly the same as the TJ, so there's nothing to gain from a swap. You don't need to replace the drag link for a boot unless the end of it's completely worn out.
Bert
What he said.
08-25-2010 05:39 AM
47MTP ZJ tie rod will fit just fine. The drag link is exactly the same as the TJ, so there's nothing to gain from a swap. You don't need to replace the drag link for a boot unless the end of it's completely worn out.
Bert
08-25-2010 04:37 AM
RoSs
ZJ Tie Rod and TJ Drag link Question

Ok so I was on the "other forum" earlier and saw some talk of the V8 ZJ Tie Rod being a direct bolt up fit on the TJ. Mine is an 03. I was wondering if this was true because I would like the larger tie rod instead of the factory one in rocking now. And also does the drag link from a ZJ work as well. The rubber boot where the Pitman Arm and drag link meet is pretty much gone on my TJ. The PO either blew it out with to much grease or just never greased it to begin with. In order to replace this do I need a new drag link or what?? Thanks for any help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC