Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Engine

Join Wrangler Forum Today


Thread: Engine Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-01-2010 11:49 PM
NM JEEPS 15 k
09-01-2010 06:15 PM
98-4Banger nvm u said u got a clutch. ya all i can think of is top up ur fluids. and see if tht changes anything, if not well i dont know what else to do, beside get it checked.
09-01-2010 06:13 PM
98-4Banger oh also question is it a auto or manual? and its possible tht the sound ur hearing is bc there is a problem in ur tranny.. in my moms dodge nitro, she accicdently was bbacking up and while holding gas poped it into drive tires spun like crazy, and i heared a ppop, second time she does it.. and well now you hear gears tranny.. its a clear sounds and not engine. also if auto when u put it in drive does it, pop? like gear engages and you feel a pop.? thts what happenign in my moms truck
08-30-2010 09:49 PM
NM JEEPS 15 also when I'm inside driving I can hear what sounds like gears turning from underneath the steering wheel
08-30-2010 09:43 PM
NM JEEPS 15 @ Tj newbie sounds like u have the same problem as me. when I accelerate it does it but as soon as I put the clutch in it stops. Tell me if u have any luck with yours
08-30-2010 09:42 PM
NM JEEPS 15 Yes we put in a brand new transmission cv joint and radiator about three weeks ago it runs fine and normally it's just that the sound scares me a little bit
08-30-2010 09:41 PM
Vroooom Is it your engine? You can hear it at idle when sitting in your driveway or at a traffic light.

Or is it the drive-train? You can hear it when you start driving.....a whining sound?

I get the whining and ive heard its fairly normal, but I'm planning to top-off my differential and transfercase fluids and see if that does any good.
08-30-2010 09:20 PM
chrisb0108
Quote:
Originally Posted by NM JEEPS 15 View Post
there is a couple of small drips of purple drips coming from the middle of the chassis. could that be it?
You need to check the fluid levels in your transmission, differentials and transfer case....have you done this yet? Any work or maintanence done recently on it? If so, what?
08-30-2010 09:15 PM
NM JEEPS 15 there is a couple of small drips of purple drips coming from the middle of the chassis. could that be it?
08-30-2010 09:00 PM
98-4Banger its obvious that its not normal.. have you checked your if everything is well lubrocated.. check see if your leaking something? maybe you can hear them because its missing lubrincant and rubbing together.
08-30-2010 07:36 PM
NM JEEPS 15 My engine is sounding a little bit different lately. it's kind of like u can hear the gears turning while your driving. is this normal?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC