Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > TJ w/ 8.8, how do you adjust the parking brake

Join Wrangler Forum Today


Thread: TJ w/ 8.8, how do you adjust the parking brake Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-23-2014 10:32 PM
Owen_TJ Edit: going to take the wheels off and use some lubricant/grease and make sure the mechanism is actually moving free behind the rotor...probably do this in the next week or two.
01-23-2014 09:50 PM
Owen_TJ Looks like i'm back to the drawing board...

Got everything completed and now my actual e-brake lever is tight and it pulls the cables but i'm not getting any grip from the brakes.
01-23-2014 05:35 PM
dove00021
Quote:
Originally Posted by WingingIt74 View Post
If you look at the pic above, I was at the end of my adjustment after my Ford 8.8 rear-end swap, so that wouldn't work.
Oh,.... well then I gots nuthin. sorry.
01-23-2014 05:34 PM
Owen_TJ I was at the end of my adjustment as well (8.8 here)...

i'm about half way through...just have a bit of a headache (was hoping it'd go away while i did this). I've got the bolt out so just need to widen the opening in the cup and rethread it.

I found my angle grinder and just cut the "v" then cut the clip and removed the bolt. Gonna go back out in a sec.
01-23-2014 05:09 PM
WingingIt74 If you look at the pic above, I was at the end of my adjustment after my Ford 8.8 rear-end swap, so that wouldn't work.
01-23-2014 05:02 PM
dove00021 My Ebrake had too much travel when I bought it and it made it completely useless, so I did what this guy did
How to adjust your hand brake (easy) - YouTube
and it totally fixed it. Took all of 15 minutes. And I still have some travel left in it too.
01-23-2014 03:33 PM
WingingIt74 I ground down the brad that holds the "V" wire, spread the wire clamp and removed the threaded rod. Also removed the "V" wire from the oval cupped piece. I then enlarged the hole just enough in the cupped piece for the threaded rod to go through.

Still has been working good
09-21-2013 07:20 PM
Owen_TJ good idea...cheers to you

i'll be doing this tomorrow so my ebrake will finally work lol
09-21-2013 07:02 PM
WingingIt74 I rotated the pics so you can see what I did better. Basically took that funky connecter out, drilled the hole slightly bigger and slid the original adjuster bolt in place. Works like a top now.
09-21-2013 06:56 PM
Owen_TJ what did you end up doing? Might follow suit with mine tomorrow...
09-21-2013 06:43 PM
WingingIt74 Here's my fix.

Old:


Fix:
09-14-2013 01:52 PM
Owen_TJ You need new lines...

the stock brake lines have too much slack and even when fully adjusted, you wont be able to make them work.

Some people have cut the stock lines and fastened new ends on them but i think you can you some XJ lines...cant remember.

do a google search and read the thread posted on jeepforum...

i'll soon be doing my lines as well. I just dont use my parking brake at the moment.
09-14-2013 09:03 AM
Bskank Tight as in the adjuster won't turn any more.
09-12-2013 08:16 AM
WingingIt74 Tight as in you can't turn the wheel, or just enough to feel them drag?
09-11-2013 09:58 PM
Bskank Loosen the middle adjuster about an inch, adjust the drums until they're are tight then back them off about 5 clicks. Then tighten the middle adjuster a few turns and check the handbrake for ebrake engagement and repeat tightening the middle adjuster and checking ebrake engagement until its good. This is what I did and its good.
09-11-2013 09:22 PM
4Jeepn If I recall correctly, the is a great deal of slop in the parking brake parts/pads.. You might just need to make sure everything is lined up.. Again, not sure that is the issue. I never connected mine on my 8.8 as I never trust parking brakes.
09-11-2013 09:14 PM
WingingIt74
TJ w/ 8.8, how do you adjust the parking brake

I adjusted the drums till they started to drag and then adjusted the middle adjuster, however the middle adjuster is bottomed out and it's still not holding very well.

What am I doing wrong?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC