Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Proper Coolant Drain, Flush, and Fill Procedure?

Join Wrangler Forum Today


Thread: Proper Coolant Drain, Flush, and Fill Procedure? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-11-2010 03:22 PM
yv4me Go to your nearest Walmart or auto parts store and buy a Prestone Flush and Fill Kit. Also buy anti freeze and distilled water. Follow the prestone instructions. Make sure you have the heater control on full hot and use ONLY distilled water for the final fill. At least 50/50 water antifreeze. Add the anti freeze first to be sure you use enough. Thats 50% of the total cooling system capacity.
09-11-2010 01:09 PM
fonecop1
Proper Coolant Drain, Flush, and Fill Procedure?

What is the proper drain, flush, and fill procedure for my 4.0 Wrangler? I started by draining the coolant from the radiator and only about 1 and 1/2 gallons came out. When I got ready to fill it up I just stuck a garden hose in the radiator and before I knew it it was run ning out of the top and wasn't going down. I went ahead and filled the overflow bottle up to full. I don't think it even took a gallon in all by my estimate.

When I started it I just let it warm up idling because I had the drive shaft unhooked doing my pinion seal. It usually runs right under the 210 mark on the temp gage but it went past 210 by a little ways and then I shut it off. I watched it and the radiator started bubling just a little bit of fluid back into the overflow bottle.

Is there a bleeder valve somewhere or something that I should have opened? I think there is a bubble in there and the thermostat isn't opening because it doen't have hot coolant touching it.
Thx,
Bob

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC