Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Need Advice ASAP!!

Join Wrangler Forum Today


Thread: Need Advice ASAP!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-12-2010 05:59 PM
Atthehop If you hear knocking or something then no oil pressure. If everythig sounds fine then sending switch. Mine was a switch a while back.
09-12-2010 05:28 PM
Jp90Talon After reading through that thread it sounds like it is something that needs to be checked just as frequent as you would rotate your tires.
09-12-2010 05:26 PM
brokejeep Good luck with getting them to pay for it. I just bought the whole assembly at the dealer because I read the entire thread on the other forum. That's why I pulled mine out & found the gear worn some. Im glad I got to mine early enough. Mines an 06 & got 30,850 miles.
09-12-2010 05:25 PM
Jp90Talon I really hope thats the case. Another Jeeper had me restart it to see if the pressure would return and it started slapping a bit (hoping it was slapping not knocking but I turned it off right away). Do you think I should even try and get a dealership to fix it or just replace it myself? I need a vehicle for work and am renting a car tomorrow. Im just pissed cause I just sold my TJ last week and OFC this happens once I am down to one main vehicle.
09-12-2010 05:19 PM
Jerry Bransford My $$$ is on there is nothing more seriously wrong with your Jeep than a bad oil pressure sender.
09-12-2010 05:18 PM
Jp90Talon
Need Advice ASAP!!

Well I was out driving this weekend and suddenly CEL's and warning buzzers gallore! Look down and I dont have any oil pressure at all. Turned it off right away and checked the oil (full no leaks) and the sensor still attached. Got it trailered all the way back to CT from NH and did a little searching on the web and came by this thread (link below). By the sounds of it this is my problem. Now I am the 3rd owner and I do not have any warrenty. Does anyone have any experiences with this or advice? It only has 50k miles on it but it does not fit within the listed recall. Any advice in getting a Jeep dealership to cover the repair?

Chrysler is paying to install a new cam (2005/2006 owners should read this) - JeepForum.com

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC