Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Need some help please

Join Wrangler Forum Today


Thread: Need some help please Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-23-2010 03:55 PM
jeepmedic4 I agree. Replace the TPS. Won't take you but a second to do it.

On a similar note on my Land Rover it required a reset with testbook (dealer software) to get the ECU to correctly read the new TPS and IACV. Does that apply to our Jeeps as well? Does the ECU need to be reset? I ask this here not to hi-jack but because it is applicable if he replaces his TPS.
09-23-2010 02:35 PM
hetiv I just had the same problem with the throttle postion sensor. Took the jeep to Checker Auto Parts, bought the sensor ($35), and the manager put it on for me right in the parking lot of the store in about 5 minutes. Just has one electrical connection and 2 allen screws (on my 2002 wrangler sport, 4.0L). Hope it helps.
09-15-2010 08:36 PM
Tsisco Ok I'll look into that rubi thank you
09-15-2010 07:14 PM
03 RUBI As far as the evap code goes I had the same problem a while back. Check the gas cap and make sure it's on tight. My cause turned out to be a little (green on mine) screw on cap up between the throttle body and the brake fluid reservoir. Tightened that (hand tight) and it solved the problem
09-15-2010 09:23 AM
Tsisco Yeah that's exactly what mine does. Some one told me that the sensor is going bad. That detects your idle. I dunno
09-15-2010 07:19 AM
Kauka I've have this same issue, but it only happens to me about once every six months. I have no idea what it is. Ive tried to recreate the problem but can't. Its impossable to trouble shoot when you have no where to look. You may have better luck finding the problem because yours sounds like it happens more.

I know thats not really any help in solving the problem, but at least you know your not alone

Plus just to give someone more infomation that might have an idea as to what it is. I have an 04 Rubi, 63k it happens to be when I come to a stop (ie: stoplight or sign) it idles real rough, rpm drops, it has died and I've kept it running buy playing with the pedal. Happens quick and is over quick, if it dies it does start up again with no problem.
09-15-2010 06:38 AM
Tsisco
Need some help please

Hi I have a 2002 tj 4.0 auto. Recently when ever I come to a stop the idle gets funky but just low and it's died a couple of times when it gos crazy the check engine light comes on. So I did the thing to get the codes an it came back with. P0122, P0123, P0455. First two are the throttle position sensor voltage low and high. Does any one know what causes this? And the other is a leak in the evaporate system. I have no clue on that. My jeep has 50 k miles on it. Any help would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC