Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In > New to Forum with a question about my 93 Wrangler

Join Wrangler Forum Today


Thread: New to Forum with a question about my 93 Wrangler Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-01-2010 04:20 AM
Yjwolf Common problem with both 4 bangers and 6 cy. There's a build up of gunk in your valve cover preventing ventilation. It's like haveing a bad PVC valve. Pull the cover clean it up real good and it should fix it. Had this prob with my 4.0 and my dads 4cy
10-01-2010 02:05 AM
Ageless Stranger Welcome to WF.
09-30-2010 01:43 PM
blkrubi88 Welcome to the forum! You might want to post your question in the YJ section for better response if you don't get an answer here!
09-30-2010 01:29 PM
tlynn77
New to Forum with a question about my 93 Wrangler

Hello out there fellow Jeepsters. I'm from Northern California and I have a 1993 jeep Wrangler 4 cyl 5 Spd 2.5 ltr.
Lately I've noticed that my check engine light comes on and that I'm going through a lot of oil with no apparent leakage places. However I did notice that there is a lot of oil building up in the breather. I took it out and cleaned it with hot soapy water and then let it dry before replacing it. The check engine light went off. Then after no more than a couple of hundred miles the light came back on and the breather was full of engine oil again. Any ideas how to solve this without payinga mechanic? Thanks all.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC