Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Club WILLYS

Join Wrangler Forum Today


Thread: Club WILLYS Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 05:38 AM
lanslide Have all the 2014s been built and delivered now? Is anyone still waiting on their '14 Willys?
Today 12:22 AM
klwillet I purchased a set of the Warn wireless W350F fog lights. I'm gonna do windshield mount for now with the Warn lights but eventually purchase the LED 2 inch block floods and connect to the wireless system. I seen a jeep at the show in York that did this and worked great.
Yesterday 10:20 PM
StarBrite
Quote:
Originally Posted by keviper1 View Post
Maybe one day someone will say that about me...
Heh... I was going to mention your note, but I see you 'fessed up!
Yesterday 10:09 PM
keviper1
Quote:
Originally Posted by 2nd04tj View Post
I was just reading about the same problem the other day. I think they said it was a faulty cam position sensor.
Yep. I read the same thread and it's been on the forum numerous times. A HUGE reason why I avoid mud at all costs.
Yesterday 10:08 PM
keviper1
Quote:
Originally Posted by Razer View Post
For those of you who have had their WW through this last winter, how did the tires perform? I've had plenty of 4x4 vehicles (including a YJ), but nothing with the mud tires that came with this one. Specifically question how they do in the rain and ice.
I've had the tires for 4 months 4k miles. Right when I picked up the Jeep I went through a blizzard in the mountains. Never put it in 4wd, zero issues. I've driven in plenty of rain, including a storm that shut down a bridge here in VA for 2 days due to rain and zero issues.

Driver has a lot to do with it, but I love the stock KMs so far.
Yesterday 10:06 PM
keviper1
Quote:
Originally Posted by chargermop View Post
They screwed up when they built his Willys they did not put it on there, kind of weird situation no buttons on the steering wheel no Bluetooth calling if I remember correctly.
Wow that's a HUGE f up on chryslers part and from what I understand not an easy thing to fix.
Yesterday 10:06 PM
Razer
Quote:
Originally Posted by chargermop View Post
So far I have no problems with the factory BF Goodrich mud terrains I had them through the end of last winter here in Colorado didn't even think twice about the weather which is big improvement from when I had my charger srt8 I would freak out at the least little bit of cold and icy conditions the jeep took it like a trooper never touched four wheel drive. As far as rain haven't had any problems been through some pretty heavy downpours I Drive 15 miles each way the highway to work tires have been a total non issue.

That is good to hear, I read mixed messages on them and was concerned about road traction.
Yesterday 09:48 PM
TexanJK Ordered a JKU WW today, Im so excited!

FireCracker Red
23W
Hardtop
Alpine Radio.

Yesterday 09:35 PM
2nd04tj
Quote:
Originally Posted by Bnlhead View Post
Ya man. Definitely down for some off-roading!
I was just reading about the same problem the other day. I think they said it was a faulty cam position sensor.
Yesterday 08:41 PM
1monday
Quote:
Originally Posted by lanslide View Post
Isn't the JK as or more capable than the TJ? Why would you want to keep it for your exclusive off-road ride vs your JK? And why relegate your JK to nothing more than your daily driver? Sorry but I don't get it.
I didn't keep the TJ, just have the JK, and right now it is my everything Jeep
Yesterday 08:39 PM
WillyWheeler
Quote:
Originally Posted by keviper1 View Post
I just purchased 2 for $17.99 on eBay. I'm gonna see if they work and put the link up once they arrive. The guy said they are for the 2011-13 but who knows, they should fit. They look the same. He said I could return if for some reason they don't fit.
I put these in a while ago, I think I got the pair from Amazon for like $30.
Yesterday 08:38 PM
chargermop
Quote:
Originally Posted by Razer View Post
For those of you who have had their WW through this last winter, how did the tires perform? I've had plenty of 4x4 vehicles (including a YJ), but nothing with the mud tires that came with this one.

Specifically question how they do in the rain and ice.
So far I have no problems with the factory BF Goodrich mud terrains I had them through the end of last winter here in Colorado didn't even think twice about the weather which is big improvement from when I had my charger srt8 I would freak out at the least little bit of cold and icy conditions the jeep took it like a trooper never touched four wheel drive. As far as rain haven't had any problems been through some pretty heavy downpours I Drive 15 miles each way the highway to work tires have been a total non issue.
Yesterday 08:33 PM
Razer For those of you who have had their WW through this last winter, how did the tires perform? I've had plenty of 4x4 vehicles (including a YJ), but nothing with the mud tires that came with this one.

Specifically question how they do in the rain and ice.
Yesterday 08:31 PM
chargermop
Quote:
Originally Posted by keviper1 View Post

I think I'm coming into this late so my apologies. How do you not have uConnect or connectivity? Can you get your PSI reading on your tires? If yes, you have the connectivity group.
They screwed up when they built his Willys they did not put it on there, kind of weird situation no buttons on the steering wheel no Bluetooth calling if I remember correctly.
Yesterday 08:26 PM
lanslide
Quote:
Originally Posted by keviper1 View Post
I think I'm coming into this late so my apologies. How do you not have uConnect or connectivity? Can you get your PSI reading on your tires? If yes, you have the connectivity group.
Yeah...I didn't understand that one either???
Yesterday 08:23 PM
keviper1
Quote:
Originally Posted by AF04DAD View Post
Thanks for the link - I was able to review the build sheet for my WW. The build sheet lists the uConnect radio and the connectivity package, but my WW does not have a uConnect radio or any connectivity. Tomorrow I have an appointment am my JK dealership to have a new radio installed. It has be about 3 months since I picked up my WW and I am just now getting the radio replaced. don
I think I'm coming into this late so my apologies. How do you not have uConnect or connectivity? Can you get your PSI reading on your tires? If yes, you have the connectivity group.
Yesterday 08:21 PM
keviper1
Quote:
Originally Posted by lanslide View Post
If it fits the 11 thru 13 I'll betcha it will fit the 14.
That's what I'm thinking, but I wanted to hit the guy up prior to ordering just to make my case if the issue comes up that I need to return.
Yesterday 08:20 PM
keviper1
Quote:
Originally Posted by lanslide View Post
Isn't the JK as or more capable than the TJ? Why would you want to keep it for your exclusive off-road ride vs your JK? And why relegate your JK to nothing more than your daily driver? Sorry but I don't get it.
TJs are extremely capable. The best part about them is that because they are less expensive you can beat them up a bit more and parts tend to be significantly cheaper than JK parts. The top Jeep I off road with is a 04' TJ. It's bad ass. It broke down on the trail a few weeks ago and it was a $300 fix. Would have been twice to three times as much on a JK.
Yesterday 08:17 PM
keviper1
Quote:
Originally Posted by Bnlhead View Post
My willys stalled on me! So I live in Denver, CO. (almost) 3 months ago I traded in my 1999 GC for the '14 JK Willys (Copperhead!) Naturally I have taken it into the mountains a bunch of times already and got some mud on the tires. Last weekend, me and a bud head up to Guanella Pass (for those of you familiar). I took a different route and ended up heading up a paved road which looked like it was heading to some scenic view. Trouble: As we are heading up, all the sudden I have almost no power, Gas pedal to the floor and not going anywhere. it quickly came back and we continued, a few minutes later, it happened again, this time absolutely going no where with the gas pedal all the way down. Then it stalled out and wouldn't not start again. I waited a few and it still wouldn't start up. After maybe 5mins it started right back up and complete power is there, its running like normal again. I had no other problems the rest of the day. Whats that all about? I mean I would assume that the elevation had something to do with it, but still, it should not of done that! I took my old GC all the way to the top of that mountain and it never did that. I called to make an appt. with the dealership, they said "its going to be like finding a needle in a haystack" since it runs fine now. But whats the alternative, be concerned that my 3 month old wrangler is going to have that problem again. ugh. Here is a pic of her doin her thing afterward:
It's possible you got mud on something in the engine compartment and it tipped a sensor. I've seen it posted a few times here. Make sure to check all your fluids and WASH your Jeep after going off road (especially with mud). Easy way to clean the underside of the Jeep - take a sprinkler and throw it under the Jeep.

Keep an eye out, but you should be fine. I wouldn't think altitude had anything to do with it as it started right back up and it's working fine now. No need to bring it to the dealer unless it's throwing a code.

Good for you for getting it dirty.
Yesterday 08:00 PM
Bnlhead
Quote:
Originally Posted by chargermop View Post
No help with your problem unfortunately but I really got to get up some of those trails up north I'm down in the springs let me know if you ever want to go out one weekend and give me a tour of some of the trails in your neighborhood.
Ya man. Definitely down for some off-roading!
Yesterday 07:13 PM
HardEcho3
Quote:
Originally Posted by AF04DAD View Post
Thanks for the link - I was able to review the build sheet for my WW. The build sheet lists the uConnect radio and the connectivity package, but my WW does not have a uConnect radio or any connectivity. Tomorrow I have an appointment am my JK dealership to have a new radio installed. It has be about 3 months since I picked up my WW and I am just now getting the radio replaced. don
Good catch! Gotta keep everybody honest these days..
Yesterday 07:08 PM
lanslide
Quote:
Originally Posted by keviper1 View Post
I just purchased 2 for $17.99 on eBay. I'm gonna see if they work and put the link up once they arrive. The guy said they are for the 2011-13 but who knows, they should fit. They look the same. He said I could return if for some reason they don't fit.
If it fits the 11 thru 13 I'll betcha it will fit the 14.
Yesterday 06:52 PM
lanslide
Quote:
Originally Posted by 1monday View Post
Let me put my 2 cents worth in. I had an '03 Rubicon vs '14 willys. Both only had/have minor cosmetic mods (so far).....hmmm...Ummmmm.... well...the ONLY things I liked better about the '03 Rubicon was the headrests and the outside door handles. I wish I had kept the Rubicon to be my off-road Jeep and the willys could just be nothing more than a daily driver.
Isn't the JK as or more capable than the TJ? Why would you want to keep it for your exclusive off-road ride vs your JK? And why relegate your JK to nothing more than your daily driver? Sorry but I don't get it.
Yesterday 06:47 PM
lanslide
Quote:
Originally Posted by mouse1 View Post
Di I sell My 04 TJ and get a Willys? I am torn. IDK what to do, lol
Absolutely YES!
Yesterday 06:42 PM
chargermop
Quote:
Originally Posted by Bnlhead View Post
My willys stalled on me! So I live in Denver, CO. (almost) 3 months ago I traded in my 1999 GC for the '14 JK Willys (Copperhead!) Naturally I have taken it into the mountains a bunch of times already and got some mud on the tires. Last weekend, me and a bud head up to Guanella Pass (for those of you familiar). I took a different route and ended up heading up a paved road which looked like it was heading to some scenic view. Trouble: As we are heading up, all the sudden I have almost no power, Gas pedal to the floor and not going anywhere. it quickly came back and we continued, a few minutes later, it happened again, this time absolutely going no where with the gas pedal all the way down. Then it stalled out and wouldn't not start again. I waited a few and it still wouldn't start up. After maybe 5mins it started right back up and complete power is there, its running like normal again. I had no other problems the rest of the day. Whats that all about? I mean I would assume that the elevation had something to do with it, but still, it should not of done that! I took my old GC all the way to the top of that mountain and it never did that. I called to make an appt. with the dealership, they said "its going to be like finding a needle in a haystack" since it runs fine now. But whats the alternative, be concerned that my 3 month old wrangler is going to have that problem again. ugh.

Here is a pic of her doin her thing afterward:
No help with your problem unfortunately but I really got to get up some of those trails up north I'm down in the springs let me know if you ever want to go out one weekend and give me a tour of some of the trails in your neighborhood.
Yesterday 06:14 PM
Bnlhead My willys stalled on me! So I live in Denver, CO. (almost) 3 months ago I traded in my 1999 GC for the '14 JK Willys (Copperhead!) Naturally I have taken it into the mountains a bunch of times already and got some mud on the tires. Last weekend, me and a bud head up to Guanella Pass (for those of you familiar). I took a different route and ended up heading up a paved road which looked like it was heading to some scenic view. Trouble: As we are heading up, all the sudden I have almost no power, Gas pedal to the floor and not going anywhere. it quickly came back and we continued, a few minutes later, it happened again, this time absolutely going no where with the gas pedal all the way down. Then it stalled out and wouldn't not start again. I waited a few and it still wouldn't start up. After maybe 5mins it started right back up and complete power is there, its running like normal again. I had no other problems the rest of the day. Whats that all about? I mean I would assume that the elevation had something to do with it, but still, it should not of done that! I took my old GC all the way to the top of that mountain and it never did that. I called to make an appt. with the dealership, they said "its going to be like finding a needle in a haystack" since it runs fine now. But whats the alternative, be concerned that my 3 month old wrangler is going to have that problem again. ugh.

Here is a pic of her doin her thing afterward:



Attachment 1326353
Yesterday 06:11 PM
1monday
Quote:
Originally Posted by keviper1 View Post
I did get a note placed on my Jeep right after I first picked it up. There is a copy of it somewhere on this thread. First chick ever to say anything close...my wife just rolls her eyes at me a lot

REALLY!!! damn, I haven't gotten a note...I want a note on the windshield.
I must be doing it wrong, haha
Yesterday 06:07 PM
AF04DAD
Build Sheet - Missing Parts

Quote:
Originally Posted by dawhitesJKU View Post
Thanks razer... Gotta check out my build sheet as well. For those that don't have it, you can email customerassist@chrysler.com and give me the last 8 alphanumeric digits of your vin or click on this link and go to "equipment listing"

Jeep - Contact Us
Thanks for the link - I was able to review the build sheet for my WW. The build sheet lists the uConnect radio and the connectivity package, but my WW does not have a uConnect radio or any connectivity. Tomorrow I have an appointment am my JK dealership to have a new radio installed. It has be about 3 months since I picked up my WW and I am just now getting the radio replaced. don
Yesterday 05:33 PM
keviper1
Quote:
Originally Posted by 1monday View Post
They probly do..."i love that hot guy in the bad a$$ willys"...you just don't know it
I did get a note placed on my Jeep right after I first picked it up. There is a copy of it somewhere on this thread. First chick ever to say anything close...my wife just rolls her eyes at me a lot

Yesterday 02:37 PM
WillysGal
Quote:
Originally Posted by NoGaBiker View Post
For those of you who don't want to travel to Napa, here are some nice charcoal filters for around 20 bucks delivered for the pair.

2011 - 2014 Jeep Wrangler - Carbon Cabin Air Filter
These work well but they do block a little bit of air flow...not a major difference, but it is noticeable to me.

Quote:
Originally Posted by mouse1 View Post
I have had my Tj for over 10 yrs. Love Her! My son purchased a JK and it is pretty nice. Like I said I am torn.
I had two TJs (2000, 2005). Loved my 2005 but there is no comparison to the JK. If you can only have one, get the JK and you won't be sorry. The ride, comfort, power.....all so much better.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC