Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Stupid Disco Questions

Join Wrangler Forum Today


Thread: Stupid Disco Questions Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-11-2010 01:18 PM
Dockman4 Tahnks for all the advice. Looks like JKS is the way to go!?! Sounds like alot of people like them.
10-11-2010 01:15 PM
Jerry Bransford I'm not saying the stud was mounted in a different location than instructed but the only time I had this problem, interference between the stud and tire, was when I installed the stud too low on the frame. I was embarassed when I discovered after re-reading the instructions that I should have mounted the stud at the very top of the frame. Once I moved the stud to the correct location per the instructions, I had no more clearance issues between the tire and the stud.
10-11-2010 12:01 PM
NHrubicon I have the JKS quick disconnects, mounted the pin forward on the frame rail like they said, and yes, if I really crank the steering wheel with 12.5" tires they rub on the sway bar, but no matter WHERE you put the pins, that sway bar is going to be in the same spot and will get rubbed. Just don't crank it or else adjust your steering bumpstops-easy enough to do. As for having to adjust (with wrench) each time you use them-that shouldn't happen-you don't drill and mount the pin until the disconnects are set for the correct height...THEN you move them forward to mark for drilling the hole.
Been running them since BEFORE I put a 4" lift on and we only had to do some minor adjustments on them afterwards-but the pin spot still works exactly like designed.
10-11-2010 11:26 AM
jgorm I have the JKS quicker discos and there was no good place where the mounting stud would fit without modifications. I think it may be due to my lift height (2.5"). I have some string to tie them out of the way.
10-11-2010 09:55 AM
530ktm JKS comes with a threaded stud you mount to the frame rail. You have to drill a hole and thread in but it keeps everything out of the way and is very easy to do. I have seen some people put this mount in the inner fender only to have the tires rub when at full turn, not good. Follow the directions and you will be fine.
10-11-2010 06:37 AM
Minn_wild1
Quote:
Originally Posted by Dockman4 View Post
Oh I like that idea. Thanks bc40ton.
X2. This looks like a good set up.
10-10-2010 11:29 PM
Brorthopa I have the JKS quick discos and I just drilled a hole, popped in some drywall anchors w/ screw and some heavy duty Velcro straps & it works just fine. Is it the coolest looking? No, but no worries! Good luck!
10-10-2010 09:11 PM
InfernoGirl Low tech solution is to zip tie them out of the way.....
10-10-2010 06:33 PM
Dockman4 Oh I like that idea. Thanks bc40ton.
10-10-2010 05:46 PM
bc40ton Just installed the RE disco's. Had to do some fitting. And I didn't like where they suggested to anchor the stud. So I cut out some brackets and welded to the shock tower. No hand tools, just a slip fit to connect/disconnect.



outta the way

10-10-2010 05:21 PM
Dockman4 Thanks for the info. I'll check out the RE disco's.
10-10-2010 04:39 PM
TXRIDER The Rubicon Express include a stud that you drill and mount to the inner fender. When you disconnect you just fold the link up and re-pin it. easy to do just have to keep a adjustable wrench with you to loosen and tighten the jam nuts when moving the links. So far I am happy with them.
10-10-2010 04:00 PM
Jerry Bransford Good discos include a way (like a frame-mounted stud) to support the antiswaybar on both sides when it is disconnected. Look at those from JKS and Rubicon Express, I'm pretty sure they do.
10-10-2010 03:55 PM
Dockman4
Stupid Disco Questions

When I got my TJ 2 months ago, I had a broken sway bar link and I replaced both of them with stock links. Now, after getting on this forum, I've decided I need to get rid of those and purchase disco's, especially when I put on my coil spring lift (which is the direction I think I'm going). Question, probably stupid, but I honestly don't know, what do you do with the sway bar when you disconnect the links? Does it just stay where it is? Do you swing it up or forward? Does it interfere if you don't? Also, what about the link itself, where does it go? Thanks. I've just been wondering this and I couldn't find it anywhere.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:58 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC