Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Issue with retention clip on the soft top Door Surrounds.

Join Wrangler Forum Today


Thread: Issue with retention clip on the soft top Door Surrounds. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-16-2010 01:44 PM
bwyman74
Quote:
Originally Posted by InfernoGirl View Post
Sounds like it wasn't getting seated properly. We had similar trouble. Once we (he) figured out how to get it to seat right, it works beautifully. (He's a smart man )
That's very possible because I was originally trying to latch it with the sunrider section open. With the top completely closed it seems to click right in. Although the right side clicked right in with the sunrider open.
10-16-2010 12:01 PM
InfernoGirl Sounds like it wasn't getting seated properly. We had similar trouble. Once we (he) figured out how to get it to seat right, it works beautifully. (He's a smart man )
10-16-2010 11:42 AM
daggo66 It must have been the threats of taking it to the dealer.
10-16-2010 10:18 AM
bwyman74 Well after a night of having the soft-top on the jeep in the up position the retention clip now works perfectly! Go figure. I just hope whatever changed stays that way.
10-16-2010 08:39 AM
InfernoGirl Just keep in mind a new one may not be any better. We bought a brand new Mopar top from the dealer.... (long story) When it came in, the holes in the frame were drilled in the wrong place, and it was missing holes in another place. Chrysler wouldn't warranty the incorrectly drilled holes, so we had to redrill in the right spot. They did however replace the part that was missing holes.....
I'd run by the dealership and take one off another Jeep, see if it works properly, and if so, then get 'em to swap you.....
10-16-2010 07:07 AM
bwyman74
Quote:
Originally Posted by Ronin View Post
I had this problem with my 09 x. I ran out of ideas and brought it to the dealer. They acted surprised like they have never had this problem before so they "adjusted" the bar and clip. All they did was take a file to the plastic surrounding the hole on the bar. It never did fit quite right. Hope your top gets better service than mine did. That was my first warranty job less than a month after I bought it.
If mine doesnt work perfectly Ill demand a new one. Hell it's a 112 dollar part thats seriously overpriced at that price. That thing couldn't have cost them more than 30 dollars to make.

Id like to try filing it myself, but that's a sure way for them to deny my warranty claim.
10-16-2010 02:36 AM
Ronin I had this problem with my 09 x. I ran out of ideas and brought it to the dealer. They acted surprised like they have never had this problem before so they "adjusted" the bar and clip. All they did was take a file to the plastic surrounding the hole on the bar. It never did fit quite right. Hope your top gets better service than mine did. That was my first warranty job less than a month after I bought it.
10-15-2010 05:24 PM
Hiker On a followup to your original locking clip problem...

Here's just another thought before you take your Jeep back to the Dealer..

First, try undoing everything on the back end of the Jeep (take out all the windows, release the back side sails and flip them up onto the top rear of the soft top).

Once you do this, the entire soft top should now move very freely.

Next, try one more time to hook those two side clips.. if you still can't get them to lock tightly.. you probably really do have a problem that they Dealer will need to fix.

Good Luck!
10-15-2010 05:05 PM
Hiker
Quote:
Originally Posted by bwyman74 View Post
Also in a slightly related note. When the sunrider is back and the pins are working properly, should you be able to just flip the sunrider forward and have the front windshield latches reach without undoing the back?
Yes!
10-15-2010 04:58 PM
bwyman74
Quote:
Originally Posted by Hiker View Post
It may be just that the latch is not fully engaging in the first place.

We also had that happen to us at first, but then after playing with it for a little bit, I noticed that the pin wasn't fully seating all the way through the hole.

In our case, all it took was just a little more wiggle to finally have it snap tightly in place.
Yeah we jiggled the crap out of it and snapped and re-snapped it with no luck. Ill try some more tomorrow before I give up and take it to the dealer.

Also in a slightly related note. When the sunrider is back and the pins are working properly, should you be able to just flip the sunrider forward and have the front windshield latches reach without undoing the back?
10-15-2010 04:23 PM
InfernoGirl That would be my guess as well... confounded new tops are way more complicated than the TJ tops....
10-15-2010 04:20 PM
Hiker It may be just that the latch is not fully engaging in the first place.

We also had that happen to us at first, but then after playing with it for a little bit, I noticed that the pin wasn't fully seating all the way through the hole.

In our case, all it took was just a little more wiggle to finally have it snap tightly in place.
10-15-2010 02:36 PM
bwyman74
Issue with retention clip on the soft top Door Surrounds.

So I just put my soft top on for the first time ever. Everything works perfectly with the exception of when I try to do just the sun-rider part back. The right side door surround retention clip holds the rail firmly in place, the left side clip allows the bar to pop-out with the slightest touch or wind.

So how are these suppose to actually work. I'm guessing this one my be bad from the factory as I literally just took it out of the box. With the exception of going to to the dealer and having to do warranty paper work to get new surrounds does anyone have any suggestions? Does anyone else's retention clip not hold the bar tightly in place?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC